View Certificate dialog buttons are missing, cannot scroll fennec on N810

VERIFIED DUPLICATE of bug 469848

Status

Fennec Graveyard
General
VERIFIED DUPLICATE of bug 469848
8 years ago
7 years ago

People

(Reporter: moz.20.storm, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.14) Gecko/2009091010 Iceweasel/3.0.14 (Debian-3.0.14-1)
Build Identifier: fennec-1.0b3

If I go to a web page with a certificate unsigned by a known CA, such as self-signed or personal secure web site with Fennec on the N810, the browser issues a "Secure Connection Failed" dialog. The options for this are "View Certificate" or Cancel. If you select View Cert, it creates a pop-up with the certificate information. The options for this particular dialog are below the bottom of the screen.

In addition, when there are pop-ups on screen like this, it disables scrolling as well as changing from windowed to full-screen. The only option seems to be killing it from an xterm.

Request scrolling be extended to pop-up windows.

Reproducible: Always

Steps to Reproduce:
1. Go to a site which has an unknown certificate authority.
2. Check the View Certificate button
3. 
Actual Results:  
Unable to close the view certificate dialog, unable to scroll the browser, unable to go full screen.

Expected Results:  
Been able to scroll the dialog to a point where the close button was available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469848
dupe v...
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.