Advanced search has empty version and milestone

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Greg Hendricks, Assigned: Greg Hendricks)

Tracking

({regression})

Bugzilla 3.6
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

V2
2.07 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
This is a result of the fix to bug 456743 and only affects tip.
(Assignee)

Comment 1

8 years ago
Created attachment 403522 [details] [diff] [review]
V1

Since Version and Milestone aren't created using Field::Choice, there is no name parameter.
Attachment #403522 - Flags: review?(LpSolit)

Updated

8 years ago
Depends on: 456743
Keywords: regression
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.6
Version: unspecified → 3.5

Updated

8 years ago
Attachment #403522 - Flags: review?(LpSolit) → review-

Comment 2

8 years ago
Comment on attachment 403522 [details] [diff] [review]
V1

This fixes the version and milestone select fields, but breaks the empty resolution in the resolution select field (a hash is printed instead).
(Assignee)

Comment 3

8 years ago
Created attachment 403539 [details] [diff] [review]
V2

id should work since if it is a Field::Choice object it will have to have one.
Attachment #403522 - Attachment is obsolete: true
Attachment #403539 - Flags: review?(LpSolit)

Updated

8 years ago
Attachment #403539 - Flags: review?(LpSolit) → review+

Comment 4

8 years ago
Comment on attachment 403539 [details] [diff] [review]
V2

Yes, now works fine. r=LpSolit

Updated

8 years ago
Flags: approval+
(Assignee)

Comment 5

8 years ago
    Checking in template/en/default/search/form.html.tmpl;
    /cvsroot/mozilla/webtools/bugzilla/template/en/default/search/form.html.tmpl,v  <--  form.html.tmpl
    new revision: 1.58; previous revision: 1.57
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.