Mac version do not know how to handle .sea.bin file format

VERIFIED FIXED

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Frank Tang, Assigned: Scott MacGregor)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b3 need info], URL)

(Reporter)

Description

18 years ago
somehow the Mac SeaMonkey do not how to handle .sea.bin format
This is serious because user won't be able to download newer version of Mac 
Netscape by using SeaMonkey

reproduce procedure-
1. Use SeaMonkey
2. visit 
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-09-08-11-M18/MacMozi
llaInstaller.sea.bin
or some other .sea.bin file or other newer build
3. SeaMonkey will tell user that it does not know how to handle it and ask you 
to save the file into the disk
4. You did that.
5. The file will be save into the disk and then if you double click it, it 
won't do anything. 

expect result-
in 3, it will download and expend the .sea.bin like 4.x did.
(Reporter)

Comment 1

18 years ago
mark it as nsbeta3, if we don't fix it and Mac users really use Netscape6 for 
their default browser, they won't be able to download new build.
Keywords: nsbeta3

Comment 2

18 years ago
I get a dialog asking if I want to save it or open it with some other app
(default other app is communicator for me).
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever

Comment 3

18 years ago
I suspect this is a dup of pchen's bugs. 
Assignee: gagan → pchen

Comment 4

18 years ago
Ok, if you click on the link for the URL in this bug report, you'll get the
dialog to "Open Using" or "Save to Disk". Because the full path is reported, you
won't see that the "Open Using" actually points to the Stuffit Expander app
which just so happens to be in your communicator folder. If you select the text
in the "Open using" text field and continue to the right to scroll the rest of
the contents, you SHOULD see Stuffit Expander at the end. Bonus useless trivia
info, if you navigate to this file, (i.e. go to "ftp://sweetlou/" and then
traverse directory tree), when you click on the installer to download, you'll
get the unknown content dialog. Mscott knows about that one.

Updated

18 years ago
Assignee: pchen → mscott

Comment 5

18 years ago
Okay, didn't see Frank's comment about what he reported as going on. Like I
mentioned previously, this is a known issue, ftp and "Save Link As..." downloads
don't use the external helper app stuff. Reassign to mscott.

Comment 6

18 years ago
Isn't the workaround to open it with an app and then choose the right app?
Whiteboard: [b3 need info]
(Assignee)

Comment 7

18 years ago
No that isn't a valid work around because we associate an incorrect creator type
with the file. So trying to open it just launches communicator.
Whiteboard: [b3 need info]

Comment 8

18 years ago
I'm not a primary machine Mac person.  Is this format the most frequently used
download type for Mac?

Updated

18 years ago
Whiteboard: [b3 need info]

Comment 9

17 years ago
Yes.  That is why nightly builds are in this format.  This is a serious bug.
Currently available workaround is typing the link in the location window and 
hitting Return.
Somehow, clicking the link brings up this bug while copying and pasting the link 
to the location window then hitting return correctly starts downloading.
The two behaviors even differ in the dialog brought up at the start of 
downloading.
(Assignee)

Comment 10

17 years ago
This is working for me on both the branch and trunk. I believe it was fixed as a
side effect of some changes I made the other night.

Marking as fixed so we can get QA to verify.

(to verify, goto ftp://sweetlou and click ona nighly .bin file. You should see
the helper app dialog come up. save to disk. Now double click on the file, it
launches unstuffit now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Has the bug 50420 been fixed, too then?

Comment 12

17 years ago
yes it has, verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.