Uninstalling lightweight theme will revert to default theme, not previous theme used

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
9 years ago
9 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
Not sure if this is expected behavior, but worth a shot.  If user uninstalls the lightweight theme, it will always restore the default theme, instead of the previously used theme.

Repro:
1) install nightly: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre) Gecko/20090929 Namoroka/3.6b1pre
2) goto URL, and install 2 or more lightweight themes in a row (enable permissions first)
3) open addons manager > themes, and uninstall the current lightweight theme you are using
4) Verify after uninstalling, the default theme of the OS appears.  i thought maybe the previously instaled lightweight theme should appear first since its MRU?

Expected (i think):
- the prior lightweight theme is shown after uninstalling the latest

Actual:
- default OS theme shown

Updated

9 years ago
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: theme → add-ons.manager
Intentional, uninstalling any non-default theme will revert to the default theme.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
by design. closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.