If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sports channel bookmark yields "bad browser" message

VERIFIED DUPLICATE of bug 55462

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 55462
17 years ago
17 years ago

People

(Reporter: verah (gone), Assigned: harishd)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
This URL comes with Netscape 6:
http://home.netscape.com/bookmark/6_0b1/sportschannel.html

However, when I click it I get an error: "Invalid browser configuration." This 
URL is a re-direct, but apparently the redirect URL isn't the problem, the 
actual Sports channel URL is the problem.

It works fine in 4.7.
(Reporter)

Comment 1

17 years ago
Nominating nsbeta3. It seems a little odd for the browser to call itself "bad" 
right in front of the users.
Keywords: nsbeta3

Comment 2

17 years ago
I'm not seeing this with Mozilla nightly 2000091308.

Comment 3

17 years ago
works for me as well with recent builds...server side fix?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
marking VERIFIED feel free to reopen if I was too 'zealous'
Status: RESOLVED → VERIFIED

Updated

17 years ago
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
This is a javascript problem.  Though you have selected that javascript be on in
N6, when you browse around, javascript is turned off.  A good example is if you
go to http://webcenters.netscape.com/shopping/home.html.  I hope this is a
duplicate bug.

Comment 6

17 years ago
trying that link with JS turned off does indeed yield the "invalid browser config" error.
Sounds like a dupe to me. Raf, do you know the JS bug number so we can dupe this?
http://jazz/users/smorris/publish/javascripttest_6.html

Stephen Morris created a test case for this problem.  It's located at the url
above.  This is a bigger problem with javascript in that it's not working.

Comment 8

17 years ago
assigning to component owner of javascript
Assignee: johng → rogerl
Status: REOPENED → NEW
Component: Bookmarks → Javascript Engine
QA Contact: claudius → pschwartau

Comment 9

17 years ago
This is not an issue for the JS engine, but for the embedding.
Reassigning to Networking for further triage -
Assignee: rogerl → gagan
Component: Javascript Engine → Networking
QA Contact: pschwartau → tever

Comment 10

17 years ago
On reexamination, Networking is not the right component for this. 

The testcase at 2000-09-15 09:17 tests the functioning of <ANCHOR> tags 
contained within <NOSCRIPT> tags, and finds the behavior incorrect. 
Therefore sending to Parser component. Please forward as necessary, 
but this is definitely not JS Engine...
Assignee: gagan → rickg
Component: Networking → Parser
QA Contact: tever → janc

Comment 11

17 years ago
I'm not seeing any of the problems being cited. Can someone please clarify what 
the specific issue is?

Comment 12

17 years ago
The only problem I was able to reproduce was the testcase at 2000-09-15 09:17.
It contains <ANCHOR> tags contained within <SCRIPT> and <NOSCRIPT> tags.
With JavaScript turned on or off in the Preferences, we are supposed to see 
the anchor rendered correctly via the <SCRIPT> or <NOSCRIPT> tags, respectively.
 

When I tried the testcase using commercial build 2000092608 on WinNT, 
I did not see the anchor rendered correctly in either case - i.e. JavaScript 
turned on or off. 


With NN4.7, both cases work correctly. You see the anchor text underlined:

        "Put the mouse here and look at the bottom of the browser"

When you put your mouse over it, you see the text of its link in the 
status bar at the bottom of the browser. 


With the commercial build above, "Put the mouse here..." is just dead text; 
it does not look or function like an anchor.
(Assignee)

Comment 13

17 years ago
Moving to my plate.
Assignee: rickg → harishd
(Assignee)

Comment 14

17 years ago

*** This bug has been marked as a duplicate of 55462 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.