Multiple prompts at the same time for http basic authentication upon session restore

RESOLVED DUPLICATE of bug 475053

Status

()

RESOLVED DUPLICATE of bug 475053
9 years ago
9 years ago

People

(Reporter: suter-20090930, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3

I have Firefox configured to re-open the same tabs (session restore).
I often have multiple tabs open for sites that use http-basic authentication.
On restart, I will receive many prompts for authentication, including many for the same domain.

Reproducible: Always

Steps to Reproduce:
1. Login via http-basic auth on multiple tabs, e.g.,
    http://basic-auth-one.example.com/
    http://basic-auth-one.example.com/
    http://basic-auth-two.example.com/
2. Restart the browser
Actual Results:  
I get three (3) prompts all at once, one per tab.

Expected Results:  
Two prompts, in serial, for each domain (or appropriate for the hostname and realm, as per the specs)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475053
You need to log in before you can comment on or make changes to this bug.