Closed Bug 519686 Opened 10 years ago Closed 10 years ago

Build localized bookmarks data for multi-locale builds and use it

Categories

(Firefox for Android Graveyard :: Bookmarks, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
fennec1.0b5

People

(Reporter: Pike, Assigned: Gavin)

References

Details

(Whiteboard: [fennec l10n])

Attachments

(2 files, 3 obsolete files)

We intend to ship a multi-locale build on maemo, and the default bookmarks should be boot-strapped with the right localizations.

We need to package that data in the chrome-% target of bug 519682, and then use it.
tracking-fennec: --- → ?
Whiteboard: [fennec l10n]
Attached patch patch (obsolete) — Splinter Review
Packages the default bookmarks in the locale jar, and loads them from there.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #405337 - Flags: review?(mark.finkle)
Attachment #405337 - Flags: review?(l10n)
Attachment #405337 - Flags: review?(mark.finkle) → review+
Attached patch updated patch (obsolete) — Splinter Review
Need to use libs realchrome rather than export.
Attachment #405337 - Attachment is obsolete: true
Attachment #406527 - Flags: review?(l10n)
Attachment #405337 - Flags: review?(l10n)
Patch works as expected on the n810 (built multi-locale with es-ES, switched my device locale to "Espanol - Espana", got spanish UI/bookmarks on first run).
Comment on attachment 406527 [details] [diff] [review]
updated patch

r=me, thanks.
Attachment #406527 - Flags: review?(l10n) → review+
https://hg.mozilla.org/mobile-browser/rev/6bc1a3d1a1ee
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Component: Linux/Maemo → General
OS: Linux (embedded) → All
QA Contact: maemo-linux → general
Hardware: ARM → All
Resolution: --- → FIXED
Target Milestone: --- → B5
backed out due to burning... will have to revisit tomorrow.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch bustage fix? (obsolete) — Splinter Review
Burning was caused by jar packaging and my rule are both using the same target, and mine came after the inclusion of rules.mk (so we were generating the file after trying to package it).

This fixes it be moving it back to export, and running export from the chrome-% target... I have no idea if there are bad side effects to doing this.
Attachment #406625 - Flags: review?(l10n)
Comment on attachment 406625 [details] [diff] [review]
bustage fix?

I guess this doesn't regenerate the bookmarks.json for each locale, I think you'll need something more like

> # Tailored target to just add the chrome processing for multi-locale builds
> chrome-%:
> 	@$(MAKE) -C $(DEPTH)/toolkit/locales chrome-$*
>+	@$(MAKE) export AB_CD=$*
	@$(MAKE) -B bookmarks.json AB_CD=$*
> 	@$(MAKE) chrome AB_CD=$*
> 	@$(MAKE) -C $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales chrome AB_CD=$*
> 

I hope that the -B and the explicit call on bookmarks.json get make to ignore that it has the file, and regenerate it per force, as make --help says. Please verify that?
Attachment #406625 - Flags: review?(l10n) → review-
Yep, that works, and ted confirmed -B exists in 3.80 in case that's an issue.
Attachment #406527 - Attachment is obsolete: true
Attachment #406625 - Attachment is obsolete: true
Attachment #406704 - Flags: review?(l10n)
Comment on attachment 406704 [details] [diff] [review]
better bustage fix

Now I think you broke the regular build. You'll need to keep the 

export:: bookmarks.json

for those. r=me with that fixed.
Attachment #406704 - Flags: review?(l10n) → review+
https://hg.mozilla.org/mobile-browser/rev/08e1a8f1201f
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Blocks: 530531
Component: General → Bookmarks
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.