Closed Bug 519689 Opened 11 years ago Closed 11 years ago

In summary collapsed threads mode, when subject of thread is small buttons are overflow

Categories

(Thunderbird :: Message Reader UI, defect)

All
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: Aureliano, Assigned: davida)

References

(Blocks 1 open bug)

Details

(Keywords: polish, Whiteboard: [no l10n impact])

Attachments

(2 files)

Attached image screenshot
If the subject of thread is small, the buttons "archive" and "delete" overflow the summary


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090930 Lightning/1.0pre Shredder/3.0pre ID:20090930031731
WFM on mac.
Sigh, yes, that's not too surprising, given that we're ignoring the buttons in the size computation.
It's not a regression as AFAIK regression is relative to released final version (2), which didn't have this feature.
Keywords: regression
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Keywords: polish
The CSS for these buttons was changed with the landing of bug 465138 so we'll need to reign them back in again before release.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0rc1
Version: 3.0 → Trunk
Whiteboard: [no l10n impact]
Attached patch patch v1Splinter Review
This should fix both this bug (which I can't repro because i only have a mac running right now) and another bug about heading sizing which I've filed but can't find.  STRs for that bug:

- find two collapsed threads, the first w/ a short subject line, the second w/ a long subject line, and one is right after the other in the thread list.
- select the first thread.
- make the window narrow enough that the first subject fits on a line, but the second thread won't fit.
- archive or delete the thread

--> before the patch, the heading doesn't resize appropriately
--> after the patch, the heading resizes appropriately whenever the thread summary is re-rendered.
Assignee: nobody → david.ascher
Status: NEW → ASSIGNED
Attachment #404650 - Flags: review?(bugzilla)
Whiteboard: [no l10n impact] → [no l10n impact][has patch, needs review standard8]
Bug 519688 is related, in that I changed the style of the buttons to match those in the message header on Windows. Without the patch, the padding is quite a bit larger, as the screenshot shows.
Attachment #404650 - Flags: review?(bugzilla) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/7de852d0812e
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][has patch, needs review standard8] → [no l10n impact]
You need to log in before you can comment on or make changes to this bug.