When adding a link to an internal anchor (<a href="#anchor">), it is not formatted as a link (unlike other links to URLs)

RESOLVED DUPLICATE of bug 229025

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 229025
8 years ago
5 years ago

People

(Reporter: Thomas D., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Steps

1 Insert > named anchor "anchor1"
2 Insert > Link > 
- set Link text to "test anchor link"
- pick "#anchor1" from Link Location dropdown

3 Insert > Link >
- set Link text to "test URL link"
- enter "http://www.asdf.com"

Actual result

for 2)
- Bug: "test anchor link" is not formatted in any way to indicate its link nature, looks like any other text (you can't tell if it is a link or not)
for 3)
- compare: "test URL link" is auto-formatted blue and underlined to show it's a link

Expected Result

- a link to an internal anchor should be formatted in the same way as other (URL) links (cf. 3): underline and font color blue

This will be especially appreciated by business users who create professional mails with links to email subsections at the top (cf. Bug 429846, comment #0).
(Reporter)

Comment 1

5 years ago
Didn't find the duplicate because it had a poor summary at the time when I filed this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 229025
You need to log in before you can comment on or make changes to this bug.