Closed Bug 5198 Opened 21 years ago Closed 21 years ago

Tables do not align properly

Categories

(Core :: Layout: Tables, defect, P3)

All
Windows 95
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: christinehoff4, Assigned: karnaze)

References

()

Details

(Whiteboard: [TESTCASE])

Using 4/16 build on Win  95, Win NT, Win 98, Mac8.5 and Linux.
Open URL. There are two left aligned tables.

Expected behavior: The first table should be left aligned. The second table
should be left aligned under the first table.

Actual behavior: The first table is left aligned. The second table is directly
to the right of the first table (cross platform).
Status: NEW → ASSIGNED
Target Milestone: M6
Moving to M8
Is this really the legacy behavior for aligned tables?  How do they interact
with align=left images?  Do they act as though they have a clear: left only when
they are after a floated table, or for everything?  I can't see your test case,
so it's hard to test.
Here is the test, David. Your questions are also ones that I would like
answered. I am not sure how they should align - this bug may not be valid.

<html>
<head>
<title>Bug 492</title>
</head>
<body>

<table border=1 align=left>
<tr>
<td>text</td>
<td>text</td>
</tr>
<tr>
<td>text</td>
<td>text</td>
</tr>
<tr>
<td>text</td>
<td>text</td>
</tr>
<tr>
<td>text</td>
<td>text</td>
</tr>
</table>

<table border=1 align=left>
<tr>
<td>text</td>
<td>text</td>
<td>text</td>
</tr>
</table>

</body>
</html>
Moving to M9.
Whiteboard: [TESTCASE]
Verified simplest testcase. Marking as [TESTCASE]...

A left-align table does not align properly when there is another table above it.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
Based on 4.x legacy behavior and traditional interpretation of align="left" as
"float: left" I am marking this bug invalid.  Mozilla layout is the same as 4.x.

Actual (4.x and Mozilla) and Expected behavior: multiple tables with
align="left" can be next to each other if room allows, just as floats can be.
"Rubber Stamping" this Verified Invalid...Chris if your questions have been
answered you can really verify it.
Status: RESOLVED → VERIFIED
tested in 4.5 and 4.7, 5.0 layout same as 4.x
You need to log in before you can comment on or make changes to this bug.