Duplicate user reviews appearing on AMO

RESOLVED FIXED in 4.x (triaged)

Status

addons.mozilla.org Graveyard
Public Pages
P5
enhancement
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Mark Cramer, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

While monitoring the reviews for https://addons.mozilla.org/en-US/firefox/addon/6549 I noticed that on a number of occasions reviews would appear twice - one immediately following the other. (I flagged the duplicates and they have been removed.) Having contacted a few of the reviewers I was told that the reviews were not entered twice, so while I'm not positive what's creating the issue, I was just able to produce it myself while entering my own review.

After submitting a review for Yoono (https://addons.mozilla.org/en-US/firefox/reviews/display/1833) I was presented with a completely blank page. When I tried to reload I was presented with a box that said something like "resubmit." After saying OK, I saw that my review was posted twice.

Reproducible: Sometimes

Steps to Reproduce:
1. Enter a review for an add-on and press "submit".
2. If you get a completely black page, click the reload button.
3. When FF asks you if you want to resubmit, click "OK".


Expected Results:  
Clicking reload and then "OK" is not an unreasonable course of action, and I'm guessing that quite a few people do it. It'd be nice if AMO was able to identify this and only accept the review once.

Having duplicate reviews is not awful, but it'd be nice to clean it up.
Severity: minor → enhancement
Priority: -- → P5
Target Milestone: --- → Future

Comment 1

8 years ago
I see this happening a lot myself.  Since the reviews are appearing twice are they also *counted* twice (and thus affecting the average "star" rating)?
It's also possible that users are double posting because they don't see their review appear after submitting it. AMO's caching policies can delay the refresh for a few minutes and sometimes even hours.

I think it would be good to detect duplicates by time and content difference, and it would also be good to show the review back to the user, so that there's at least an impression that something happened.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: Future → 4.x (triaged)

Comment 3

8 years ago
The duplicates I've been seeing are exact copies of each other, including typos.  So I think it is unlikely the user is actually filling out the form more than once.  As mentioned in the op, reloading the page is probably the culprit.  If the user gets a blank page instead of an immediate confirmation the review was submitted and pending, it would be a natural reaction to reload the page.
we have new code for reviews, so this shouldn't be happening anymore.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.