Closed Bug 519828 Opened 15 years ago Closed 14 years ago

Firefox does not change output device when set under Windows audio setting

Categories

(Firefox :: General, defect)

3.5 Branch
x86_64
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aquinashub, Unassigned)

References

()

Details

(Whiteboard: [CLOSEME 2011-2-25])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

I have multiple sound outputs on my motherboard, the standard 3.5mm speaker output and a digital optical.  If have one of them set as the "default" under Windows audio and switch to the other, Firefox continues to output to the old output.  Other applications respect this change, but Firefox does not.

Reproducible: Always

Steps to Reproduce:
1. Open a web page that has audio output
2. Test audio through output device
3. Close Firefox
4. Change audio device
5. Re-open Firefox
6. Test audio and find it outputs through wrong device.
Actual Results:  
The audio outputs through the previous audio device.

Expected Results:  
The audio should output through the new selected device.
Version: unspecified → 3.5 Branch
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
I am seeing this issues as resolved in Firefox 4 Beta 10.  Marking it as resolved.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
This still affects me, doesn't work for me with Windows 8 and Nightly 27.0a1.

When I change default audio output device in Windows Control Panel, Firefox still uses old device unless I restart FF.
(In reply to Dāvis from comment #3)
> This still affects me, doesn't work for me with Windows 8 and Nightly 27.0a1.
> 
> When I change default audio output device in Windows Control Panel, Firefox
> still uses old device unless I restart FF.

I see the issue as described in comment 3.  However, comment 0 specifically includes restarting Firefox as part of the STR - so I can't reproduce the problem as initially described.

Whether Firefox should respect the new default device dynamically (ie, without restarting) is an interesting question, but doesn't seem to be the point of this bug.  I can't find a bug on that specific behaviour, but most apps I use seem to work the same way, so I suspect that bug would be WONTFIX.  That said though, feel free to open one if you feel strongly about it.
seems I didn't read carefully and yeah I'll open new bug, because IMO it's bug.
You need to log in before you can comment on or make changes to this bug.