Page content (animated GIF's) shifts without user interaction

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jerry Baker, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Using 2000090708, this page loads a banner ad at the top. After about 5 - 10 
seconds, the banner mysteriously shifts to the left about 5px. Is something 
triggering a reflow well after the page is already loaded? This is a cosmetic 
bug, but random shifting of page contents may be disconcerting to users. This 
occurs on other pages as well and URL's will be added to this bug report as they 
are encountered.
(Reporter)

Comment 1

18 years ago
http://www.cadcamonline.com

It appears to be related to animated GIF's. It is always occuring where there 
are animated GIF's anyway. On this page, just load it and watch the area around 
the animated GIF shift around at random. Reload to watch it again. Playing with 
clicking in the page and mousing over things sometimes causes weird shifting as 
well.
(Reporter)

Updated

18 years ago
Summary: Page content shifts without user interaction → Page content (animated GIF's) shifts without user interaction
(Reporter)

Comment 2

18 years ago
It appears that it *is* animated GIF's and that after one full loop of the GIF, 
the GIF is then shifted to the left.
Dividing up Claytons bugs to triage
Assignee: clayton → rods

Comment 4

18 years ago
This looks fine on today's WinNT build, it will have to be tested on Win2000, 
reassigning to kmcclusk
Assignee: rods → kmcclusk
Seems fine to me on Windows 2000 Commercial build 2000091805. Also seems fine
on Linux Commercial build 2000091806. 

Jerry: can you verify this is fixed?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Well, I'm not the QA so I don't want to step out of my place, but it appears 
WFM.

Comment 7

18 years ago
verified. using the 2000092808 m18 nightly on win2k.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
It's back with 2000101008.

Updating URL field.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

17 years ago
Note to anyone trying to reproduce: Watch the animated gif in the right frame 
till the shape changes three times.
(Reporter)

Comment 10

17 years ago
What builds are you using? It's still doing it on my 2000110205 Win32 build.
(Reporter)

Comment 11

17 years ago
Damn...wrong bug window...sorry
Reassigning to attinasi:
Marc, this should be fixed when you check in your fixes to prevent the
generation of reflows for animated gifs.
Assignee: kmcclusk → attinasi
Status: REOPENED → NEW
(Assignee)

Comment 13

17 years ago
Probably will be, but that will just mask a reflow problem I think. If we are 
reflowing and it is shifting then couldn't we be having an incremental reflow 
problem here?

Chris, do you want to check this out before I close down the reflow?
Status: NEW → ASSIGNED

Comment 14

17 years ago
Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
VERIFIED wfm (6/8 build, win2k) -- the banner ad is apparently gone, and I 
didn't see any issues with the animated image(s).
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 17

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.