Applications freeze because firefox don't interact correctly by handling focus with other applications.

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
9 years ago
8 years ago

People

(Reporter: dominik.mueller, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Changing between minimized firefox and other applications could freeze the other apps. This presupposed a special handling which is wirtten in the following sections.

Reproducible: Always

Steps to Reproduce:
1. Start firefox.
2. Start a C or Delphi application with integrated TPopupMonthCalenderEH elements.
3. Minimize the firefox and change to the other application.
4. Change back to firefox and maximize it.
5. Change to the other application and you see it's freezed.
Actual Results:  
If you working with firefox and minimize it to start work with other open applications, firefox does not send correctly the focus to this other application.

If you now change from the other app to the firefox and later back the application with the TPopupMonthCalenderEH element grays out, freeze and does not react of any interaction. This application can only been terminated by using the task manager. After a restart of the app you can countinue working.

This bug is only in connection with applications which uses a TPopupMonthCalenderEH element. The application will freeze immediately by changing from firefox back.



Expected Results:  
The minimized firefox must send the focus to the next active application so that you can work without any interuppting.

After a few tests of oures developers we found out that all apps with this element got freezed. This happens only in interact with the firefox. Interacting with other software run correctly. 

I think the problems are two things:

1. The firefox eventhandling or focus handling does not work with any application which uses standard C, C++, C# or Delphi libaries.
2. Through this behave the other applications will possibly lose criticly data.

So the severity is of course "critical"

We found this mistake by using a application with the named element to save the working times and done tasks of our Employees.

The shown programm in the demonstration site is a dummy which uses the same element like the programm which strike the bug. 

For security reasons we could not show the original program.
(Reporter)

Updated

9 years ago
Keywords: calendar-integration
Priority: -- → P1
Whiteboard: Firefox 3.5.3, focus, delphi, event handling
Version: unspecified → 3.5 Branch
(Reporter)

Updated

9 years ago
Summary: Applications freeze while firefox don't interact correctly by handling focuses with other applications. → Applications freeze while firefox don't interact correctly by handling focus with other applications.
(Reporter)

Updated

9 years ago
Summary: Applications freeze while firefox don't interact correctly by handling focus with other applications. → Applications freeze because firefox don't interact correctly by handling focus with other applications.

Updated

9 years ago
Keywords: calendar-integration
(Reporter)

Comment 1

9 years ago
Today I've installed the Firefox Update 3.5.4.!
Now the delphi applications doesn't freeze anymore, so a normal work with this is possible.
	
But there's any consolation, the fiefox still doesn't handle the correct focus.
SO  the bug is resolved only partially. The app greys out and react of any interaction.

Please correct the handling of focus, and this Bug could be marked as fixed.

Comment 2

9 years ago
Same here - not the odd problem with the delphi app. 
But the incorrect handling of focus of other apps when minimizing firefox. This bug is really annoying, especially if you have to switch between firefox and another app frequently, say to test html/css as a webdesigner where you always switch between editor and firefox.

Bug is always reproducable on my Windows maschine with any app.

I would be pleased to have this bug actually corrected.

Comment 3

9 years ago
Here another description of this bug: http://forums.mozillazine.org/viewtopic.php?f=38&t=456298
(Reporter)

Comment 4

9 years ago
Yea that true,

all applications witch uses several event libaries let the browser freeze.
So not only delphi apps!

(In reply to comment #2)
> Same here - not the odd problem with the delphi app. 
> But the incorrect handling of focus of other apps when minimizing firefox. This
> bug is really annoying, especially if you have to switch between firefox and
> another app frequently, say to test html/css as a webdesigner where you always
> switch between editor and firefox.
> 
> Bug is always reproducable on my Windows maschine with any app.
> 
> I would be pleased to have this bug actually corrected.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Priority: P1 → --
Whiteboard: Firefox 3.5.3, focus, delphi, event handling → [CLOSEME 2011-2-25]
(Reporter)

Comment 6

8 years ago
This issue doesn't appears in the 3.6.x versions anymore!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

8 years ago
see upper!
Status: RESOLVED → VERIFIED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.