Select All, Copy, Paste will paste text which is not visible on the rendered page

RESOLVED DUPLICATE of bug 39098

Status

()

RESOLVED DUPLICATE of bug 39098
9 years ago
9 years ago

People

(Reporter: mbid, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

If any page has css element display:none, it will not be rendered by firefox, however doing a select all and copy/paste into notepad, you can see the text. Ideally a select all, copy/paste should only paste the text visible to the user. 

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.risesmart.com/tr.html
2. Do a Select All (or control A) and copy
3. Paste into notepad
4. There is text which says "This will text will not be seen" which can be seen in the pasted text but not on the rendered page
Actual Results:  
"This will text will not be seen" is seen on the pasted results

Expected Results:  
"This will text will not be seen" should not be seen

Hide all text which is not visible on the rendered screen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 39098
You need to log in before you can comment on or make changes to this bug.