Weave's Custom Settings (e.g. "Keep me signed into Weave") aren't saved until you sign in to weave.

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: UI
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-weave1.0 +

Firefox Tracking Flags

(Not tracked)

Details

STEPS TO REPRODUCE:
 1. Visit about:weave.  Sign out of Weave, if you're signed in.
 2. Click the "Custom settings" tab below the sign-in box.
 3. Click the "Keep me signed into Weave" checkbox to change its status.
      (If it was originally checked, leave it unchecked; & vice versa)
 4. Quit firefox.
 5. Visit about:weave, and open "Custom settings"

EXPECTED RESULTS:
 Checkbox should be how you left it in step 3.

ACTUAL RESULTS:
 Checkbox is still in its original state, before step 3.

If you repeat this process with one modification -- sign in to weave after step 3 -- then the checkbox-update will persist.  Otherwise, it seems to be ignored.

(I think this applies to the "Encrypt my data and save it with:" radio button, too, though I haven't tested that button as much.)

I'm running Weave 0.7 with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091001 Minefield/3.7a1pre
Summary: Weave's "Custom Settings" (e.g. "Keep me signed into Weave") aren't saved until you sign in to weave. → Weave's Custom Settings (e.g. "Keep me signed into Weave") aren't saved until you sign in to weave.

Updated

8 years ago
Flags: blocking-weave1.0+

Updated

8 years ago
Target Milestone: --- → 1.0
about:weave is dead, this checkbox is going away too.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.