Last Comment Bug 520056 - Update Effective TLD list for .za.net and .za.org
: Update Effective TLD list for .za.net and .za.org
Status: RESOLVED FIXED
: verified1.9.0.16, verified1.9.1
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla1.9.3a1
Assigned To: Peter Kasting
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-01 13:15 PDT by Norman Rasmussen
Modified: 2009-11-23 10:44 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta2-fixed
.6-fixed


Attachments
patch for za-nic (313 bytes, patch)
2009-10-01 13:17 PDT, Norman Rasmussen
no flags Details | Diff | Splinter Review
za-nic.patch (550 bytes, patch)
2009-10-01 16:34 PDT, Norman Rasmussen
gerv: review+
Details | Diff | Splinter Review
patch w/email address [Checkin: Comment 14] (1.07 KB, patch)
2009-10-19 14:23 PDT, Peter Kasting
jst: approval1.9.2+
samuel.sidler+old: approval1.9.1.6+
samuel.sidler+old: approval1.9.0.16+
Details | Diff | Splinter Review

Description User image Norman Rasmussen 2009-10-01 13:15:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.24 Safari/532.0
Build Identifier: 

The effective TLD list does not contain ".za.net" or ".za.org".  I have asked the .net and za-nic registrars before (circa Jul'08) if they would include it, but they have not responded.

Patch coming shortly.

Reproducible: Always
Comment 1 User image Norman Rasmussen 2009-10-01 13:17:01 PDT
Created attachment 404108 [details] [diff] [review]
patch for za-nic
Comment 2 User image Peter Kasting 2009-10-01 13:32:29 PDT
Comment on attachment 404108 [details] [diff] [review]
patch for za-nic

I'm not sure these should go here; perhaps they should instead be split into two pieces that go near .net and .org.  This is how the CentralNic domain names (e.g. ".se.net") were done.
Comment 3 User image Norman Rasmussen 2009-10-01 16:34:54 PDT
Created attachment 404157 [details] [diff] [review]
za-nic.patch

updated patch, re: Peter's comments
Comment 4 User image Peter Kasting 2009-10-01 16:42:26 PDT
Comment on attachment 404157 [details] [diff] [review]
za-nic.patch

Remember to re-request review.
Comment 5 User image Gervase Markham [:gerv] 2009-10-02 00:46:49 PDT
Comment on attachment 404157 [details] [diff] [review]
za-nic.patch

We don't accept submissions not from the owner of the domain. If we add someone's domain to the list without their permission and their websites break, that would be really bad. If they don't ask us, we have to assume they are happy with the way things work now.

Gerv
Comment 6 User image Peter Kasting 2009-10-02 10:34:30 PDT
Comment on attachment 404157 [details] [diff] [review]
za-nic.patch

That doesn't make sense.  You accept submissions from me and Pam.  This case is obviously broken today (try actual usage), and there's a registrar with a public policy that backs up the suggested fix.

Please rethink.
Comment 7 User image Gervase Markham [:gerv] 2009-10-02 14:49:28 PDT
I'm happy to update the list when someone says "hey, this ICANN-accredited registrar's policy document over here says something different". But adding pseudo-registrars is a different kettle of fish. 

Think of the trouble it would cause if we added google.com to the list. Now, you may say that people are not running za.net or za.org like google.com. But without asking them, we have no way of knowing what they are doing. Maybe they have valid uses for cookies shared across the whole domain. It's not right for us to break that without their permission.

If someone from the owners of za.net and za.org comes in here and says "sure, go right ahead, we've looked at what it'll mean and it's clearly the right thing" (like CentralNIC did) then no problem, let's go.

Gerv
Comment 8 User image Peter Kasting 2009-10-02 15:04:03 PDT
I don't agree, but the fastest way to resolve this would definitely be to get an official reply from the owners.  Accordingly, I've emailed the contact address for ZA NiC, and CCed you.  Please correct or add to my mail as necessary :)
Comment 9 User image Peter Kasting 2009-10-16 10:47:58 PDT
Gerv, are you OK with doing this based on the email reply we got?  I don't think your final message to the registrar looked like one that needed a further response.
Comment 10 User image Gervase Markham [:gerv] 2009-10-16 23:51:18 PDT
We got a reply? It must have gone to my spam folder. Can you give me the message details and I'll dig it out :-)

Gerv
Comment 11 User image Peter Kasting 2009-10-19 12:13:35 PDT
Ah, checking the mail again, it looks like they replied to me without CCing you.  Sorry for not noticing that.  I have forwarded you the reply.
Comment 12 User image Gervase Markham [:gerv] 2009-10-19 14:14:47 PDT
Comment on attachment 404157 [details] [diff] [review]
za-nic.patch

Please put the email address of the guy who emailed us in the comment (like centralnic). With that change, r=gerv.

Gerv
Comment 13 User image Peter Kasting 2009-10-19 14:23:11 PDT
Created attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]

Patch as requested
Comment 14 User image Serge Gautherie (:sgautherie) 2009-10-20 15:20:52 PDT
Comment on attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]


http://hg.mozilla.org/mozilla-central/rev/cdebeb90dbd8
Comment 15 User image Gervase Markham [:gerv] 2009-10-23 03:17:16 PDT
Comment on attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]

Requesting branch approvals.

Gerv
Comment 16 User image Daniel Veditz [:dveditz] 2009-10-23 10:44:47 PDT
Comment on attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]

The only reason we'd want this on the 1.9.0/1.9.1 branches is to stay in sync with 1.9.2 so we'll wait for that to get approved.

At this stage in 1.9.2's life-cycle the drivers are not looking at the huge list of non-blocker apprvals so you'll need to bug people on IRC or email to get any notice.
Comment 17 User image Gervase Markham [:gerv] 2009-11-04 06:45:40 PST
Checked in on 1.9.2.

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/c37fe45bfce822ed2e4ea141f8ba1b7793aee4db

Gerv
Comment 18 User image Gervase Markham [:gerv] 2009-11-04 06:46:13 PST
Comment on attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]

Renominating to keep 1.9.1 and 1.9.0 in sync.

Gerv
Comment 19 User image Samuel Sidler (old account; do not CC) 2009-11-04 15:33:01 PST
Comment on attachment 407115 [details] [diff] [review]
patch w/email address
[Checkin: Comment 14]

Approved for 1.9.1.6 and 1.9.0.16. a=ss for release-drivers
Comment 20 User image Gervase Markham [:gerv] 2009-11-05 03:55:29 PST
1.9.0.x:

Checking in netwerk/dns/src/effective_tld_names.dat;
/cvsroot/mozilla/netwerk/dns/src/effective_tld_names.dat,v  <--  effective_tld_names.dat
new revision: 1.12; previous revision: 1.11
done

1.9.1.x:

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b9e65f1a7d7976d408e6fcfea2b570733cebc018

Gerv
Comment 21 User image Al Billings [:abillings] 2009-11-23 10:44:27 PST
Verified for 1.9.0.16 and 1.9.1.6 in source.

Note You need to log in before you can comment on or make changes to this bug.