photos can not be forwarded

RESOLVED DUPLICATE of bug 307023

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 307023
9 years ago
9 years ago

People

(Reporter: JAMES STARLEY, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)
Build Identifier: 

I can send photos from to myself and others but, if I get pics from somebody else and try to forward them the text goes through but the photos will be blank

Reproducible: Always

Steps to Reproduce:
1.receive email with pics in them
2.forward it to several addresses
3.
Actual Results:  
They receive text but, no pics

Expected Results:  
That the pic would be sent as well as text

This problem just started today
Please give us the version of thunderbird. Are you forwarding as attachment or inline ?
(Reporter)

Comment 2

9 years ago
I CAN NOT FIND THE VERSION OF THUNDERBIRD BUT, IT'S THE UP DATED VERSION. I AM NOT FORWARDING AS AN ATTACHMENT BUT, IE YOU SEND ME INLINE PICS WHEN I PRESS FORWARD THE PICS GO AWAY SO THEY DO NOT GET SENT. THANKS

Comment 3

9 years ago
I'm seeing the same prob.

Spanking fresh install, XP SP3, TB 2.0.0.23.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Problem example:

Received email has pics inline, that are *not* attachments.

Try to fwd (inline) this email - pics are replaced with red x-boxes in the composition window and if sent the recipient gets no pics.

Checking props for images (while composing email) shows some probs:
- first letter of URI is truncated (ailbox:/// or ile:///)
- later in the URI there are a pair of removed chars (an equal sign and the subsequent digit, as visible below)
- a double-quote char gets appended to the URI (seems to be non-harmful tho)
- my guess is that there's a bad char[] offset: 1-based is being implemented where 0-based should instead be used (accounts for the truncated 'ailbox:///' and the extraneous double-quote char
- dunno what's causing the removal of the '=' sign and the subsequent char tho

Orig email's pic shows props:
mailbox:///C|/Documents%20and%20Settings/gram/Application%20Data/Thunderbird/Profiles/__SALT__.default/Mail/shawmail.gv.shawcable.net/Inbox?number=396747430&part=1.1.2&filename=image.png

Fwd'd (while composing) email's pic (now represented with red 'X') shows props:
ailbox:///C|/Documents%20and%20Settings/gram/Application%20Data/Thunderbird/Profiles/__SALT__.default/Mail/shawmail.gv.shawcable.net/Inbox?number96747430&part=1.1.2&filename=image.png"

I'll be willing to help further is someone wants to email me...
freeman
at
reazon.dyndns.org (change letter 'zed' to letter 'ess')

Bummer for me, wanted to move mom (senior citizen) to TB - she moved over but can't fwd her emails, so it's back to OE :(  :(  :(

Updated

9 years ago
Component: General → Message Compose Window
QA Contact: general → message-compose
Version: unspecified → 2.0

Comment 4

9 years ago
Fixed in Thunderbird 3.0. As a workaround in 2.0, use Reply rather than Forward and replace the name of the original sender with your intended recipients, this shouldn't show the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307023
(Reporter)

Comment 5

9 years ago
I LOADED THUNDERBIRD 3.0 AND THE PROBLEM IN IT IS FIXED.  THANKS GUYS VERY MUCH. JIM STARLEY   jimstar@alaweb.com

Comment 6

9 years ago
So where do I download 3.0?

Comment 7

9 years ago
http://www.mozillamessaging.com/en-US/ (currently 3.0 beta 4)

Comment 8

9 years ago
I used 3.0 beta 4.  If you just click Forward (or Reply), the format is set as Autodetect, and no images are sent.  If you manually change the format (which is under Options and NOT the Format button) for each message to HTML only, the images do go out.  I did this in sending to myself, and in sending to others on Comcast.net, who are set to send and receive in HTML only.

This is more of a workaround than an actual fix. 

Either a global option should be allowed to set format as Send in HTML, or the default format should be whatever was last used.
You need to log in before you can comment on or make changes to this bug.