Firefox spikes CPU core usage to 100% after a few minutes of usage

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: nadim, Unassigned)

Tracking

3.5 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

To my knowledge, this is limited to 3.5.3 and is damn annoying.
Just using Firefox for a few minutes will make it start occupying a whole CPU core for itself, keeping it at a constant usage level of 99%. On a dual-core system, this results in 50% of the CPU going off for Firefox. Even if the browser's displaying only one very minimalistic page, CPU's still going through the roof.
This seems to be unrelated to RAM or network resources, as both seem to stick to tolerable levels.

I'm labeling this as critical because it's just ridiculous that it eats up half the overall CPU power of most Macs out there every single time, causing battery drain, heat issues, loss of productivity, etc. etc.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox 3.5.3
2. Wait a few minutes
3. Watch CPU meter
Actual Results:  
CPU usage on one core spikes to 99% even if Firefox is idle

Expected Results:  
CPU usage to remain reasonable and relative to how much work Firefox is handling

Theme:
Foxdie (Graphite) - http://foxdie.us

Extensions:
Adblock Plus
Better Gmail 2
Download Statusbar
Fast Dial
Fission
Foxdie for Firefox
Full Fullscreen
Smarterfox
Does this happen with a fresh firefox profile? http://support.mozilla.com/en-US/kb/Managing+profiles?s=profile
Severity: critical → major
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
It appears that the bug is caused by the Foxdie (Graphite) theme and the Foxdie for Firefox extension. Disabling these resulted in CPU usage dropping back to normal.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Please report to the developers of those extensions.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.