Display of HTML Message display includes a different message

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Randy Orrison, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-09-15])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When I open a recent Tor.com email, which uses a table for layout, the contents of the table is replaced with the complete text (including headers) of an earlier unrelated email.  (Both messages are in my Inbox, on an IMAP account.)  Using mutt on the server verifies that the bodies are still correct on the server.

Reproducible: Didn't try

Steps to Reproduce:
1. Receive email from 123-reg.co.uk and Tor.com
2. Read them both ok
3. Wait.  Close Thunderbird.  Do other things.  Open Thunderbird again.
Actual Results:  
The main table within the body of the Tor.com email now displays the 123-reg.co.uk email.  This is now consistent for these two email messages; I haven't seen it happen with any other messages.


Will attach screenshots of the message as displayed and message list.
(Reporter)

Comment 1

9 years ago
Created attachment 404222 [details]
Thunderbird displaying 123-reg email inside Tor.com email
(Reporter)

Comment 2

9 years ago
Created attachment 404224 [details]
Inbox message list showing Tor.com email and 123-reg email
Randy what happens if you rebuild the index of the folder that contains the message ?

Are all those messages in the same folder ?
Version: unspecified → 3.0
(Reporter)

Comment 4

9 years ago
The messages are in the same folder, the Inbox of an IMAP account, there are 300+ messages in the folder, and the two arrived about 4 hours apart (the second attachment is a snippet from the Inbox view).

I haven't tried rebuilding the index; if that fixes the problem will this bug entry be marked resolved?  Is there anything that would be useful to help determine the cause of the problem that may be lost by rebuilding the index?
(In reply to comment #4)

> I haven't tried rebuilding the index; if that fixes the problem will this bug
> entry be marked resolved?  Is there anything that would be useful to help
> determine the cause of the problem that may be lost by rebuilding the index?

a copy of the .msf file that is going to be rebuild might help. That would tell us what is borked in it - but wouldn't tell us how it got borked which would be the important part to fix that kind of bug.
(Reporter)

Comment 6

9 years ago
Rebuilding the index cleared the problem.  I have a 7zipped copy of the msf file, which I am slightly reluctant to upload (in case there's any potentially sensitive information in it).  If someone is going to investigate this bug and thinks it will help, I could email it to you (it's 62KB).
David ^^^?
Randy send me the email and make sure to mention the number of the bug.
Whiteboard: [closeme 2011-09-15]
RESOLVED INCOMPLETE due to a lack of response to previous question. If you feel this change is in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 10

7 years ago
Two years and four major versions later, and I haven't been able to find the zipped file with the msf file in it.  I haven't seen the problem again since I reported it, so I'm happy for it to be closed.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.