xmlhttprequest with wrong credentials for http authentication should not resulting in prompting the user

RESOLVED DUPLICATE of bug 282547

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 282547
9 years ago
9 years ago

People

(Reporter: Jakob Jensen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.24 Safari/532.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

When making a XMLHttpRequest with HTTP authentication and using wrong credentials, firefox will prompt the user for credentials, which it should not do according to the current working draft of W3C regarding XMLHttpRequest.

Reproducible: Always

Steps to Reproduce:
See http://codereaper.com/bugspray/javascript/xmlhttprequest/httpauthentication


Expected Results:  
It should have captured the event and noticed that credentials wore sent along with the request and not prompted the user, but instead have used the error message sent from the server along with the 401 header.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 282547
You need to log in before you can comment on or make changes to this bug.