active tab indication is too subtle / cannot see the tab focus outline (activity, contrast, invisible)

VERIFIED FIXED in fennec1.0

Status

--
minor
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: Aleksej, Assigned: mfinkle)

Tracking

Fennec 1.1
fennec1.0
x86
Linux

Details

(Whiteboard: [fennecb4testday] [polish])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Fennec 20091001, desktop linux-i686.

I am using an old "Iiyama HM703UT A" CRT monitor. These have contrast issues, so you cannot see both very dark and very bright colours and have a good display configuration.

At my current setting (20-30% brightness, 40-50% contrast) I cannot see the black frame around the active tab thumbnail, or see it with a great difficulty.
Whiteboard: [fennecb4testday]
(Reporter)

Updated

9 years ago
Summary: active tab indication is too subtle / cannot see the tab focus outline → active tab indication is too subtle / cannot see the tab focus outline (activity, contrast, invisible)
(Assignee)

Updated

9 years ago
Duplicate of this bug: 528538
(Assignee)

Updated

9 years ago
tracking-fennec: --- → ?
Keywords: access
Whiteboard: [fennecb4testday] → [fennecb4testday] [polish]
Bringing my comment from the duped bug over here:

This selection border is not visible enough.  In the usability tests, it seemed
to be contributing to a slowness in understanding what the tab sidebar was
about in some users (i.e. people would tap, but not realize that their
currently selected tab was changing).
Created attachment 415279 [details]
some options, both going darker and using other colors from the UI

the ones with a light background require a background-grey keyline around the thumbnail
the two darker grays are:

darker:      1b1c20  (RGB: 27 28 32)
darker yet:  0c0d10  (RGB: 12 13 16)

the blue is the highlight blue from fennec (9cc6e4), and the light grey is the one we use for separator rows (efebef).
Created attachment 415347 [details] [diff] [review]
patch

Patch using the "darker yet" color, which I think Madhava was leaning towards.

Madhava - what say you?
Assignee: nobody → mark.finkle
Attachment #415347 - Flags: review?(gavin.sharp)
Attachment #415347 - Flags: review?(gavin.sharp) → review+
Yes - let's see how well this works.  I like the idea of the blue, but I don't think it's quite right yet, whereas the "darker yet" gray does the job.  Darker gray it is.
pushed:
https://hg.mozilla.org/mobile-browser/rev/507cc96fd0dd
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
I don't see a difference and I think it's even harder to notice this with a mobile device with a glossy screen when under a light.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Tried some new variants of the blue outline, and I think we have an improvement.

These were the variants:
http://www.flickr.com/photos/madhava_work/4153261795/sizes/o/

After looking at them on device:
http://www.flickr.com/photos/madhava_work/4153205997/

The consensus seems to be that the 4:4 variant works the best.  That is - 4px of background gray and then 4px of highlight blue.  The outer border has rounded corners, as the current outline does, whereas the gray area inside has square corners.
Created attachment 415722 [details] [diff] [review]
patch

Uses border colors to create the 4:4 effect
Attachment #415347 - Attachment is obsolete: true
Attachment #415722 - Flags: review?(gavin.sharp)
Comment on attachment 415722 [details] [diff] [review]
patch

>diff --git a/themes/wince/browser.css b/themes/wince/browser.css

> box[type="documenttab"][selected="true"] .documenttab-canvas {

>+  border: 0.8mm solid;

>+  -moz-border-top-colors: #8db8d8 #8db8d8 #8db8d8 #8db8d8 #36373b;

I'm guessing this doesn't work very well if the border ends up being less than 8 pixels... Not sure whether that's likely, but perhaps we should use px here?
Attachment #415722 - Flags: review?(gavin.sharp) → review+
aren't we supposed to be using px for everything now?
We didn't make that switch for WinCE.
Also - screenshot please!
(In reply to comment #11)
> (From update of attachment 415722 [details] [diff] [review])
> >diff --git a/themes/wince/browser.css b/themes/wince/browser.css

> I'm guessing this doesn't work very well if the border ends up being less than
> 8 pixels... Not sure whether that's likely, but perhaps we should use px here?

Changed to 8px for checkin. That should be safe.

(In reply to comment #14)
> Also - screenshot please!

http://people.mozilla.com/~mfinkle/fennec/screenshots/fennec-tab-selection.png
pushed:
https://hg.mozilla.org/mobile-browser/rev/9e4d9c448fbf
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
looks great! verified FIXED on builds:

Mozilla/5.0 (Windows; U; Window3sCE 5.2; en-US; rv:1.9.2b5pre) Gecko/20091203 Namoroka/3.6b5pre Fennec/1.0a4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091203 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091203 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.