Closed Bug 520240 Opened 12 years ago Closed 12 years ago

js1_5/extensions/regress-420869-01.js, js1_5/extensions/regress-424683-01.js - FAIL

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bc, Unassigned)

References

Details

(Keywords: regression, testcase, Whiteboard: fixed-in-tracemonkey)

+++ This bug was initially created as a clone of Bug #519999 +++


js1_5/extensions/regress-420869-01.js | Throw too much recursion instead of script stack space quota Expected value 'InternalError: too much recursion', Actual value 'InternalError: script stack space quota is exhausted'  item 1

js1_5/extensions/regress-424683-01.js | Throw too much recursion instead of script stack space quota Expected value 'InternalError: too much recursion', Actual value 'InternalError: script stack space quota is exhausted'  item 1
Flags: in-testsuite+
dvander, 

would you mind going ahead and marking the regressing tests in the js1_5/extensions/jstests.list manifests as failing until you have fixed this? Simply prefix the test file name with fails. There are several examples in the manifest.

Then remove the fails when checking in the fix?
http://hg.mozilla.org/mozilla-central/rev/7f314c0c1a22
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
These tests do *appear* to be fixed on or around 10/07, but not by the referenced revisions since those just mark the tests as failing in the manifests. I do see one winxp box where they are still failing, but others where they are not. 

Regardless, the manifests need to be updated to reflect that the tests are no longer failing. I'll do that when I get a cleaner picture of the situation on windows.
These tests definitely pass on mozilla-central, tracemonkey on all platforms, but I wonder what the correct test should be here and in bug 514139. Should I just use reportMatch and treat either result as passing?

Luke's position in bug 514139 is that either result is ok for e4x/Regress/regress-319872.js and depends on the operating system behavior. If that is true for that test, then are these tests overconstrained?
http://hg.mozilla.org/tracemonkey/rev/0b9150c8beda
mark js1_5/extensions/regress-420869-01.js, js1_5/extensions/regress-424683-01.js as passing.
reopening since this is not yet on mc.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: fixed-in-tracemonkey
http://hg.mozilla.org/mozilla-central/rev/0b9150c8beda
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.