Panning occurs when highlighting text in Fennec UI

RESOLVED WORKSFORME

Status

Fennec Graveyard
Panning/Zooming
--
major
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Fennec 1.1
x86
Mac OS X
polish

Details

(Whiteboard: [fennecb4testday])

(Reporter)

Description

8 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/200910002
Fennec/1.0b4

Steps to Reproduce:
1. Save a bookmark
2. Go to the Bookmarks Manager
3. Click on manage
4. Select the bookmark and try to highlight text in the page title and/or url field.

Actual Results:
There's a slight horizontal pan when highlighting the text

Expected Results:
Panning should not occur while highlighting text. It's disorienting.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Whiteboard: [fennecb4testday]
This is happening on the N900/N810? I can't reproduce it.
Blocks: 521561
(In reply to comment #1)
> This is happening on the N900/N810? I can't reproduce it.

I can reproduce it easily on desktop with a vertical pan instead of a horizontal one. (Furthermore, the horizontal pan should never happened on bookmarks now).

So, do we want the panning to not occur at all when some text is being selected or this bug is related to horizontal pan?
Using the mouse/panning to highlight text is a complete accident. We do not explicitly want that to happen. Especially since we don't do it consistently anywhere else in Fennec.

I suspect it has something to do with horizontal panning (or lack of it in my case)

I'd suggest we fix horizontal panning (should not happen) and let the text highlighting issues for a more general Fennec-wide bug.

Updated

8 years ago
tracking-fennec: ? → 1.0-
(Reporter)

Comment 4

8 years ago
Horizontal panning is fixed, but i still vertically pan when trying to highlight fields in manage bookmarks mode
(Reporter)

Updated

8 years ago
Duplicate of this bug: 530557
(Reporter)

Comment 6

8 years ago
This happens in both the Addons Manager and Bookmarks Manager.
Summary: Panning occurs when highlighting text in Manage Bookmarks mode → Panning occurs when highlighting text in Fennec UI
(Reporter)

Updated

8 years ago
Component: General → Panning/Zooming
(Reporter)

Updated

8 years ago
Keywords: polish
(Reporter)

Comment 7

8 years ago
THis is still happening to me on today's nightly builds.
tracking-fennec: 1.0- → ?

Comment 8

7 years ago
sfm
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.