Alt+V in text field pastes text

VERIFIED FIXED

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Dean Tessman, Assigned: Akkana Peck)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It's 2am and I can't find the proper component for this.  Also probably 
the reason that I couldn't find this already in bugzilla.  Someone please 
re-assign to the proper component or declare this a dupe.  Thanks...

Steps:

1. Copy some text into the clipboard.
2. Put focus on the Location field.
3. Press Alt+V (V while still holding down Alt).

Expected Results: View menu pops down

Actual Results: copied text is pasted into the location field

This isn't specific to the location field, it happens in any text field (eg. the 
fields on this bug report form).

Build: 200090808

Comment 1

18 years ago
Looks like somebody made a mistake between the keyboard shortcuts.  ALT+V 
should activate the view menu and CTL+V should paste the text.
(Reporter)

Comment 2

18 years ago
Forgot to mention that Ctrl+V will paste as well.  Either it's a duplicate 
shortcut or something deeper.
(Assignee)

Comment 3

18 years ago
Talked to hyatt, and we have a handle on this.  There was a change made to the
xbl event listener that got the wrong key modifier.  The fix is straightforward
and I'll be doing it.
Assignee: beppe → akkana
Keywords: nsbeta3, regression
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 4

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
verified in 9/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.