Last Comment Bug 520359 - pymake fails to build Firefox
: pymake fails to build Firefox
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.3a1
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on:
Blocks: 485412 C192ConfSync
  Show dependency treegraph
 
Reported: 2009-10-03 04:01 PDT by Mitchell Field [:Mitch]
Modified: 2010-03-08 03:45 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta5-fixed


Attachments
Patch v1.0 (2.10 KB, patch)
2009-10-03 04:01 PDT, Mitchell Field [:Mitch]
benjamin: review+
mbeltzner: approval1.9.2+
Details | Diff | Review
Patch v1.0 (Part Deux) (773 bytes, patch)
2009-10-03 04:04 PDT, Mitchell Field [:Mitch]
wtc: review+
Details | Diff | Review

Description Mitchell Field [:Mitch] 2009-10-03 04:01:13 PDT
Created attachment 404411 [details] [diff] [review]
Patch v1.0

Building Firefox from mozilla-central, using pymake currently fails.

This patch fixes the non-NSPR parts. (Ted did all the work.)
Comment 1 Mitchell Field [:Mitch] 2009-10-03 04:04:46 PDT
Created attachment 404412 [details] [diff] [review]
Patch v1.0 (Part Deux)

This patch fixes the NSPR part. (Again, Ted did all the work.)
Comment 2 Benjamin Smedberg [:bsmedberg] 2009-10-03 08:56:41 PDT
Comment on attachment 404411 [details] [diff] [review]
Patch v1.0

>diff --git a/config/config.mk b/config/config.mk

> ifeq (,$(filter-out WINCE,$(OS_ARCH)))
> NSINSTALL	= $(CYGWIN_WRAPPER) nsinstall
>-INSTALL     = $(CYGWIN_WRAPPER) nsinstall 
>+INSTALL     = $(CYGWIN_WRAPPER) nsinstall
> endif

Did you mean to use HOST_BIN_SUFFIX here, or why did you change this line at all?
Comment 3 Ted Mielczarek [:ted.mielczarek] 2009-10-03 09:33:15 PDT
I think I did initially change that, but then reverted it, but I guess I wound up removing some trailing whitespace there.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2009-10-05 09:36:47 PDT
Comment on attachment 404412 [details] [diff] [review]
Patch v1.0 (Part Deux)

wtc, this is needed to get through a build with pymake, because `pwd` prints an MSYS path, and pymake wants Windows-style paths. $(CURDIR) has been available since GNU Make 3.77.
Comment 5 Wan-Teh Chang 2009-10-05 11:06:50 PDT
Comment on attachment 404412 [details] [diff] [review]
Patch v1.0 (Part Deux)

r=wtc.

This construct is also used in mozilla/security/coreconf/rules.mk:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/security/coreconf/rules.mk&rev=1.81&mark=394,400,403,409,413#388
Comment 6 Ted Mielczarek [:ted.mielczarek] 2009-10-05 11:12:37 PDT
It looks like we're ok there, since they explicitly handle Win32 paths. We could probably simplify that whole block to use $(CURDIR), though.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2009-10-07 04:47:24 PDT
Comment on attachment 404412 [details] [diff] [review]
Patch v1.0 (Part Deux)

Landed on NSPR trunk:
Checking in config/rules.mk;
/cvsroot/mozilla/nsprpub/config/rules.mk,v  <--  rules.mk
new revision: 3.73; previous revision: 3.72
done
Comment 8 Ted Mielczarek [:ted.mielczarek] 2009-10-08 11:12:00 PDT
Pushed the other patch to m-c:
http://hg.mozilla.org/mozilla-central/rev/ccb86dc8e0da

We'll need to get NSPR updated on trunk to pick up the other fix.
Comment 9 Ted Mielczarek [:ted.mielczarek] 2009-10-20 05:42:03 PDT
I updated NSPR on m-c, so this should all work again:
http://hg.mozilla.org/mozilla-central/rev/d82fe5d73822
Comment 10 Mike Beltzner [:beltzner, not reading bugmail] 2009-12-02 15:54:42 PST
Comment on attachment 404411 [details] [diff] [review]
Patch v1.0

a192=beltzner
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2009-12-03 09:42:09 PST
pushed http://hg.mozilla.org/releases/mozilla-1.9.2/rev/171e66b6364d

Note You need to log in before you can comment on or make changes to this bug.