Crash [@ objc_msgSend | -[ChildView keyDown:] ] when I search on different terms

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
critical
RESOLVED WORKSFORME
8 years ago
a month ago

People

(Reporter: Stuart Lamble, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Mac OS X
crash
Bug Flags:
camino1.6.11 -

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Version 1.6.10 (1.8.1.23 2009092522)

After performing an initial search on seek.com.au (an Australian job search website), I can enter alternative search terms in the top left text field. After submitting this data, seek then displays a pop-up telling me to wait while the request is processed. When I confirm this pop-up, Camino crashes.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.seek.com.au/
2. Enter keywords in the field that request them.
3. Submit the search (note that the URL given provides the end result of these three steps.)
4. Enter new keywords in the field.
5. Click on "Submit".
6. Click on "Ok".
Actual Results:  
Camino crashes.

Expected Results:  
Camino should just display the page and operate as normal.

Crashlog will be attached very shortly.
(Reporter)

Comment 1

8 years ago
Created attachment 404476 [details]
Output from crash reporter.

Comment 2

8 years ago
I can reproduce this is 1.6.10 as long as I replace step 5 with "hit return"; clicking Seek doesn't seem to bring up the dialog.

The good news is that it's fixed in 2.0b4, but since this is so easily reproducible I'll see if there's anything simple we could do in ChildView to prevent this on the 1.6 branch.
Assignee: nobody → stuart.morgan+bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Version: unspecified → 1.8 Branch
(Reporter)

Comment 3

8 years ago
*headdesk*

Sorry. You're right, "hit return" is what I was actually doing; somehow I got that and "click on submit" mixed up in my mind. As penance, I shall go forth and install Windows ME ... ;)
Flags: camino1.6.11?
Keywords: crash
Summary: Crash when I search on different terms. → Crash [@ objc_msgSend | -[ChildView keyDown:] ] when I search on different terms
FWIW, on 10.3.9 I get a -[NSView interpretKeyEvents:] frame between objc_msgSend and -[ChildView keyDown:].

Comment 5

8 years ago
This is pretty ugly. The key-down handling spawns the alert, which runs a modal loop; during that modal loop the ChildView we are currently running keyDown: in is autoreleased and dealloc'd, then we come back from the dialog and try to keep running the method in the now-destroyed object.

There's nothing super-easy I can see to do here, and I'd be worried about causing some subtle regression in other more common key handling cases if I try to do something tricky. Given that, I think we should just call this WFM (since it doesn't happen in 2.0).
Assignee: stuart.morgan+bugzilla → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: camino1.6.11? → camino1.6.11-
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ objc_msgSend | -[ChildView keyDown:] ]

Comment 6

a month ago
a similar problem was experienced at http://jobapplicationaustralia.com , http://jobapplicationcanada.com
 and fixed in 2.0b4, but since this is so easily reproducible I'll see if there's anything simple we could do in ChildView to prevent this on the 1.6 branch.
You need to log in before you can comment on or make changes to this bug.