Named windows lose their name upon Firefox restart

UNCONFIRMED
Unassigned

Status

()

Firefox
General
--
major
UNCONFIRMED
9 years ago
4 years ago

People

(Reporter: Peter Gruendler, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

To reproduce, popups must be allowed for the affected website.
Furthermore, Firefox must be set to reopening the windows from the previous session.

The details popup window (named "Popup") opened by clicking on one of the two links over the popup window is reused when selecting the other link (and most other links on the site, e.g. "Blitzaktivität"). As long as the popup window is open, firefox obviously remembers its name, shown by closing the tab with the main site and reloading the site again in a new tab.
The Popup window is opened via javascript; the anchor tag contains an onClick property.

When "Exit"ing firefox and starting it again, The main window (containing a tab with the affected site) as well as the site's popup window will be opened.
Selecting one of the links on the site's map reopens a new popup window.


Reproducible: Always

Steps to Reproduce:
1. set firefox to allow popups and do remember the last session's URIs
2. proceed as detailed in the "Details" section.
3.
Actual Results:  
After restarting firefox, the affected site opens a new named popup window.

Expected Results:  
The previous session's named popup window should be reused.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe
> mode?

The problem is still present in 3.6.12

> Also, please consider using the most recent Firefox 4 beta build,

With 4b7, the problem is still present *AND* firefox becomes unresponsive when executing the testing steps described. Firefox must then be killed using the task manager's process tab.
(Reporter)

Updated

8 years ago
Severity: normal → major
(Reporter)

Comment 3

8 years ago
changed importance to major due to the 4b7 behavior.
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)

retested in 3.6.13 and in 4.0b8 using a new profile.
behavior as described.
named popup window loses its name upon exiting and restarting firefox.
If this behavior can not be verified, I can e.g. provide a screen movie showing me reproducing it.

I think i provided the exact steps enabling anyone to reproduce the erroneous behavior. reports welcome.

reset tp unconfirmed. kept importance as major because this affects basic browser features while not disturbing normal browsing.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Could you give a screenshot or screencast? It would be most helpful.
Whiteboard: [CLOSEME 2011-1-1]
Version: unspecified → Trunk
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Could you give a screenshot or screencast? It would be most helpful.

http://gruendler.org/download/ff_lnw.avi

shows (4.0b8, new profile) how the URI is opened, a popup window opens when selecting an anchor in the main window, and subseqzent anchors are directed to this popup.
then ff is closed remembering windows, and reopened.
selecting anchors in the main window open a fresh popup window.
this is repeated 4 times.

Comment 8

7 years ago
Can you attach a simple HTML example the exhibits the issue?

Comment 9

7 years ago
Peter -> Can you attach a test case or provide a public url?
(Reporter)

Comment 10

7 years ago
I've written a very simple test case:
http://gruendler.org/bugzilla/bugzilla_testcase_named_popup/

it's easyest used when "use new tabs instead of new windows" is deselected in options.

useage instructions on the test page.
p

Updated

4 years ago
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.