can't scroll with the mouse if the scrollable area is inside an "a" link tag (scrollbar dragging → container dragging)

RESOLVED DUPLICATE of bug 367028

Status

()

RESOLVED DUPLICATE of bug 367028
9 years ago
7 years ago

People

(Reporter: steelerbg, Unassigned)

Tracking

1.9.1 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20110902], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5 (.NET CLR 3.5.30729)

When there is a container inside of an <a> link, and the container is with a scrollbar (i.e. overflow: auto and fixed height) when trying to scroll with the mouse it instead grabs a preview of the whole <a> and allows me to move it around like and image inside an <a> would. The scrolling works with the keyboard and the mouse wheel, but not when it's clicked and draged

Reproducible: Always

Steps to Reproduce:
1. create an <a> tag.
2. put a scrollable area inside (i.e. <span style="height: 150px; overflow: auto; float: left; width: 150px;">) 
3. put some content inside so that the scroll appears
Actual Results:  
not scrollable with the mouse

Expected Results:  
it should be scrollable with the mouse
Component: General → Layout
Keywords: qawanted
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.1 Branch

Comment 1

7 years ago
Created attachment 557860 [details]
Example test case used to reproduce this bug

Confirmed this bug. See attached HTML file for an example test case. My test case details are below:

Steps: 

1) Open scrolltest.html
2) Click the scrollbar slider and drag it to the right. 

Expected: Scrollbar slider and internal container should move to the right.
Actual: The container is dragged towards the right, scrollbar slider does not move, container does not move.

Build Information:

Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110902 Firefox/9.0a1

Updated

7 years ago
Attachment #557860 - Attachment mime type: text/plain → text/html

Comment 2

7 years ago
Confirmed with:
7.0b2
Todays Nightly Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110902 Firefox/9.0a1

The scrollbar works properly for a short way, so it can be scrolled in small steps. A longer scroll-drag becomes drag of the container.
Whiteboard: [testday-20110902]

Updated

7 years ago
OS: Windows Vista → All
Summary: can't scroll with the mouse if the scrollable area is inside an "a" link tag → can't scroll with the mouse if the scrollable area is inside an "a" link tag (scrollbar dragging → container dragging)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367028

Updated

7 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.