Setting @src on already-loaded <video> and <audio> doesn't load new file

RESOLVED DUPLICATE of bug 478805

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 478805
9 years ago
9 years ago

People

(Reporter: Michael A. Puls II, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre) Gecko/20091005 Namoroka/3.6b1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre) Gecko/20091005 Namoroka/3.6b1pre (.NET CLR 3.5.30729)

When you do:

audio_element.src = "file1.ogg";
audio_element.play();
audio_element.src = "file2.ogg"
audio_element.play();

file2.ogg never plays. You have to insert a .load() after setting the src the second time to get it to work.

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478805
You need to log in before you can comment on or make changes to this bug.