calendar-event-dialog-freebusy.xml should use getAnonymousElementByAttribute in place of getElementById.

RESOLVED FIXED in 1.0b1

Status

defect
--
trivial
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: prasad, Assigned: martinschroeder)

Tracking

(Blocks 1 bug)

Trunk
1.0b1
Dependency tree / graph

Details

Attachments

(2 attachments)

... silly mistake but causes not displaying the freebusy status.
Attachment #404815 - Flags: review?(philipp)
The first change in the patch is already covered by Bug 520399.
(In reply to comment #1)
> The first change in the patch is already covered by Bug 520399.

I think this bug is more general than bug 520339, so that one can be marked as duplicate of this one.
Duplicate of this bug: 520399
Comment on attachment 404815 [details] [diff] [review]
[checked in] Fix

I kind of wonder what we are actually *doing* in that file. A binding must not have anything with an "id" attribute, since it could be used more than once and the "id" attribute must be unique in the document. prasad (or Decathlon?) could you investigate why and if possible change id="..." to anonid="..." in that file?
will look at it
Assignee: nobody → prasad
Status: NEW → ASSIGNED
I suggest to fix the issue now using the attached patch and proceed with investigation afterwards.
Flags: blocking-calendar1.0?
Blocks: 428035
I have been experiencing "No information" display in Lightning and Sunbird 1.0pre (using CalDAV talking to an Exchange server through DavMail). The patch fixes this problem for me, so I would appreciate if it could find its way into 1.0
Comment on attachment 404815 [details] [diff] [review]
[checked in] Fix

r=mschroeder
Attachment #404815 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Whiteboard: [leave open after checkin]
We need a follow-up patch to fix the usage of "id" attributes. Two of them can be easily replaced by the "anonid" with the same value ("day-column", "grid-column"). Replacing the "id" attribute with value "attendeeCol4#1" seems to be more complicated because the element uses an "id" and "anonid" attribute.
Keywords: checkin-needed
Whiteboard: [leave open after checkin]
Flags: blocking-calendar1.0?
This just fixes the two easy cases, but for the third one I still try to understand how all those XBL bindings for the freebusy dialog work and could be simplified.
Assignee: prasad → mschroeder
Attachment #411070 - Flags: review?(philipp)
Attachment #411070 - Flags: review?(philipp) → review+
Comment on attachment 411070 [details] [diff] [review]
[checked in] Replace id with anonid (easy fix)

Looks good, r=philipp
Comment on attachment 411070 [details] [diff] [review]
[checked in] Replace id with anonid (easy fix)

http://hg.mozilla.org/comm-central/rev/dada8caded1b

http://hg.mozilla.org/releases/comm-1.9.1/rev/73549b0972eb
Attachment #411070 - Attachment description: Replace id with anonid (easy fix) → [checked in] Replace id with anonid (easy fix)
Summary: even-dialog-freebusy.xml should use getAnonymousElementByAttribute in place of getElementById. → calendar-event-dialog-freebusy.xml should use getAnonymousElementByAttribute in place of getElementById.
I don't see any recent activity here, is this something that could be considered for 1.0?
(In reply to comment #14)
> I don't see any recent activity here, is this something that could be
> considered for 1.0?

Could be considered for 1.0? Yes! But I haven't found time to work on this bugs in the last 6 months.
Assignee: mschroeder → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
I think we have these covered, I couldn't find getElementById in calendar/base/content/dialogs/*.xml
Assignee: nobody → mschroeder
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b1
You need to log in before you can comment on or make changes to this bug.