OS/2 browser doesn't show anything in the main window

RESOLVED FIXED

Status

Core Graveyard
Widget: OS/2
--
critical
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: Walter Meinl, Assigned: Rich Walsh)

Tracking

Firefox Tracking Flags

(status1.9.2 beta2-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.3a1pre) Gecko/20091006 Minefield/3.7a1pre
Build Identifier: 

After checkin of bug515446 the browser builds fine, address bar and bookmarks are present, the tabs show the title of a webpage opened but not the page (and scrollbars, which may be absent because there's nothing to scroll). The main window is just a background.
Not surely (but most likely) related opening the history or bookmarks window will crash the browser.
Since the bits of bug515446 were also checked into 1.9.2 we will have to find a fix soon.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 515446
Version: unspecified → Trunk
(Assignee)

Comment 1

8 years ago
Got it fixed, patch in a few minutes...
Assignee: mozilla → dragtext
(Assignee)

Comment 2

8 years ago
Created attachment 404997 [details] [diff] [review]
fix widget creation failure

The problem was these lines in nsWindow::Create where hwndP was accidentally redefined.
  HWND hwndP = (HWND)aNativeParent;
  if (!hwndP) {
    HWND hwndP = aParent ? [etc]
  }

Since this code was a mashup of two previously separate methods, it was ..uhh.. confusing so I rewrote it for greater clarity.
Attachment #404997 - Flags: review?(mozilla)
Uouhps. Sorry for not paying enough attention.

Updated

8 years ago
Attachment #404997 - Flags: review?(mozilla) → review+

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4634de0ae97c
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

8 years ago
This needs to be pushed to the 1.9.2 branch as well.  I just looked at that version of nsWindow.cpp & found the same error there.

Comment 7

8 years ago
This was apparently too late for beta1, at least the tag FIREFOX_3_6b1_RELEASE does not contain the change.
status1.9.2: beta1-fixed → final-fixed
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.