Closed Bug 520941 Opened 11 years ago Closed 10 years ago

Remove last search term from sidebar query

Categories

(support.mozilla.org :: Search, defect, P4, minor)

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephend, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot
(Initially targetting 1.5 for this, since it's related to search.)

Although we set a cookie named "fsearch" with the value of the last-entered term on the little "Search the Knowledge Base" search box, we don't appear to read it and populate said box with the search term.

This is broken even on production, too.

STR:

1. Load http://support-stage.mozilla.org/en-US/kb/
2. Type "firefox crashes" and click the orange search arrow
3. Look at the "Search the Knowledge Base" textfield on the resulting page (http://support-stage.mozilla.org/tiki-newsearch.php?where=all&locale=en-US&q=firefox+crashes&sa=)

Expected:

"firefox crashes" should appear in the search box

Actual:

Search box is empty
We discussed this in bug 517269
See bug 517269 comment 6 (David's comment). Correct me if I misunderstood, but I believe we're removing this functionality.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
(In reply to comment #2)
> We discussed this in bug 517269
> See bug 517269 comment 6 (David's comment). Correct me if I misunderstood, but
> I believe we're removing this functionality.

He makes an exception for the search-results page, "I don't see the point of remembering the value of the search box for any pages BUT the search results page."

The resulting URL given in step 3 (http://support-stage.mozilla.org/tiki-newsearch.php?where=all&locale=en-US&q=firefox+crashes&sa) is just that, no?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
From David's comment, I understood that we want the search box to contain a value "on the search results page" -- which is NOT for the Forum and KB (bigger) search boxes?
:)

David, can you clarify it for us?
That's right - the search box should only contain the results on the search results page, which is the URL Stephen refers to (tiki-newsearch.php) in comment 3.

Essentially, if you search for something, the search box in the resulting page includes the string you searched for, but if you navigate to other pages or go to the start page again, it shouldn't remember the string (unless you went back to the start page by hitting the Back button of the browser, in which case the text will be remembered anyway).

However, from an implementation point of view, I don't really understand why we need a cookie to prefill the search results page, since the searched string is part of the form submission (and even the URL). Can't we just ditch the cookie and just show the string on tiki-newsearch.php anyway?
We don't need a cookie, from an implementation point of view. We should stop setting it at all.

From a usability point of view, I think we should add a search form to the top and bottom of the results, pre-populated with the last search term, and not pre-populate the search box in the sidebar. That makes the search more familiar (see most search engines) and makes refining searches more intuitive.

The sidebar search, being on every page, seems disconnected from the "current" search, and doesn't need to match.
Is this wontfix or invalid?
(In reply to comment #7)
> Is this wontfix or invalid?

If we're going to implement the solution proposed in comment 6, we could either morph this bug or file anew; I don't care either way, really.
Component: General → Search
I say we close this. There's already a bug about adding a search box to the search page (relating to comment 6).
Morphed. We don't need to do this via a cookie and we don't need it in the sidebar.
Keywords: regression
Summary: "Search the Knowledge Base" textfield should read "fsearch" cookie and populate/fill the sidebar search boxes → Remove fsearch cookie
Severity: major → minor
Priority: -- → P4
I thought I had already removed the cookie? I can check tomorrow.
Fixed by bug 527959 comment 4.
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → FIXED
Summary: Remove fsearch cookie → Remove last search term from sidebar query
Verified FIXED; don't see any more "fsearch" cookies.
Status: RESOLVED → VERIFIED
Fixed on prod.
(In reply to comment #14)
> Fixed on prod.

Verified; searched, and still no more fsearch cookie(s).
You need to log in before you can comment on or make changes to this bug.