Font size in table / tables grows up and destroys the layout

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: rschwaag, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

when i click 10 times fast in the menu at "Turniere" the font size of the content table will grow up and the layout crashes. with ie 7 or ie 8 everything works without bugs. the linked url is w3c validated too.

Reproducible: Sometimes

Steps to Reproduce:
1. go to this link http://www.pokerden.de/index.php?section=turnier&action=list
2. click very fast 10 times in the menu at "Turniere"
Confirming with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre (.NET CLR 3.5.30729)

and

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

You don't need to click fast, just click the "Turniere" link on the left. It seems to be time dependent if you get the same page but with a bigger table. The table has neither class nor id, so it's the table stuff in the CSS which should be the problem.

It's also no caching issue, maybe completely random?
Status: UNCONFIRMED → NEW
Component: General → DOM: CSS Object Model
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
I can't reproduce this on Windows Vista with latest trunk with html5.enable to true. But I do see it with html5.enable to false.
(Reporter)

Comment 3

8 years ago
if you want I can upload a screenshot?
(Reporter)

Comment 4

8 years ago
When you make this:

* #content td
{
    font-size:12px;
}

the error is a little bit fixed. now the table dont crashes. but the border color changes to from black to gray. ;)
(Reporter)

Comment 5

8 years ago
It's just a fix. Not a real solution, or?
I can't reproduce this (the increased font-size) with Firefox 3.0 so it seems a regression. I'll try to find more info about the regression later, if I'm lucky within 12 hours.
Keywords: regression
I can't reproduce it anymore, possibly the code of the page has changed.
If you want to keep this bug open, you need to upload a testcase:
https://developer.mozilla.org/en/Reducing_testcases
In any case this bug will probably be fixed for Firefox 4, when html5.enable will be set to true by default.
You can try it out:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
and in about:config set the preference html5.enable to true.
Description here: http://kb.mozillazine.org/About:config
Keywords: regression
QA Contact: general → style-system
Sounds like this was fixed by the html5 parser.  Please reopen if that's not the case.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Component: DOM: CSS Object Model → Layout
QA Contact: style-system → layout
You need to log in before you can comment on or make changes to this bug.