Closed Bug 521003 Opened 10 years ago Closed 5 years ago

(Message header) Can't copy date or subject of message (CTRL+C)

Categories

(Calendar :: Lightning Only, defect, minor)

Lightning 1.0b1
x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aureliano, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

In message header, I can copy (usually with CTRL+C) subject of the message, but I cannot copy date of message.

It is All OS related?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091007 Lightning/1.0pre Shredder/3.0pre ID:20091007032014
works for me Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20091007 Shredder/3.0pre
Attached image screenshot
Confirmed also with 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091009 Lightning/1.0pre Shredder/3.0pre ID:20091009032155

Wayne can you confirm on Windows?
not even selectable. 20091007  XP
was it ever?
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #4)
> was it ever?

Yes, I think it is: when I attempt to make this first time I can't (no regression range).
See also bug 540729
I also share the same bug on Thunderbird 3.0.1 running on Windows 7 (32bits). 

I try to Ctrl+C the e-mail subject and it don't work. It I right click it and select copy, then it works.
Duplicate of this bug: 541330
I have exact same bug than Martin with Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100216 Lightning/1.0b1 Thunderbird/3.0.2

But the good news is that Ctrl+C on mail subject is working fine Lanikai Alpha 1 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2pre) Gecko/20100119 Lightning/1.1a1pre Lanikai/3.1a1 ID:20100119130202


Can anyone using Lanikai confirm my test? I've alos the feeling that an extension maybe involved. Can anyone try to test in safe mode
You are right about the safe mode. I had run Thunderbird under safe mode and the bug didn't showed up. I can copy and paste in safe mode.

I had disabled
- Lightning 1.0b1
It requested me to also disabled
- Provider for Google Calendar 0.6b1.

So with both disabled the Copy the subject function works.
Tested with:Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3 ID:20100227143138

I finally succeed to start TB v3 in SafeMode.
I can also Copy & Paste

So this bug probably involves an extension

**************************
Martin,

Are you sure that only Lightning is involved in this bug?

To go one step further could you please give us your list of extensions.
Nightly Tester Tools extension may help you.
https://addons.mozilla.org/en-US/thunderbird/addon/6543
Tools => Nightly Tester Tools => Copy List of Extensions to Clipboard

Please find below list of my extension:
AttachmentExtractor 1.3.5
Dictionnaire français «Réforme 1990» 3.5
Display Mail User Agent 1.6.5
Duplicate Contact Manager 2 1.2
Fournisseur pour Google Agenda 0.6b1
FoxClocks 2.5.46
Funambol Mozilla Sync Client 0.9 [DISABLED]
Lightning 1.0b1
Nightly Tester Tools 2.0.3
Quicktext 0.9.10.1
Quote Colors 0.3
Remove Duplicate Messages 0.1.07
Return Receipt Toolbar Button 0.13
SamePlace 0.9.4.2010012600 [DISABLED]
Signature 0.4.20070429 [DISABLED]
Slideshow 1.3
Trier les dossiers manuellement 0.4.4
United States English Dictionary 4.0.0
WebMail - Hotmail 1.2.24 [DISABLED]
WebMail 1.3.5 [DISABLED]
xmpp4moz 0.7.2.2010020221 [DISABLED]

Do we have only Lightning in common?
Regression Test:

WFM with: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100227 Lightning/1.1a1pre Thunderbird/3.0.3 ID:20100227143138

Not working with: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3 ID:20100227143138

Same TB version different Lightning version => different result
It seems that Lightning is the problem.

Somewhere in between Lightning/1.1a1pre and Lightning/1.0b1 something got wrong.

I assume that to find a more accurate regression window,I should look at
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/
Is it correct ?

I found Build ID of 1.1apre: 20100213041302
Does anyone knows BuildId of 1.01b1?

I'm confused: Lightning/1.1a1pre before Lightning/1.0b1 ?
Here it is my plugins list:

Diccionario español Argentina 2.0
gContactSync 0.2.12
Lightning 1.0b1 [DISABLED]
Locale Switcher 2.1
Nightly Tester Tools 2.0.3
Provider for Google Calendar 0.6b1 [DISABLED]

If I turn on Lightning the bug appears.
Lightning development, like most Mozilla development, proceeds along multiple lines at once (although there is relatively little parallelism right now). So it's perfectly possible for it to be fixed in a 1.1a1pre build of a date earlier than 1.0b1's failure -- though in this case, I don't believe that's actually the case, see below.

At any rate, this does seem to be a Lightning bug (no pun intended), so moving. (I have the vague feeling that this is a dup, but I'm not at all sure of that, and didn't find anything. Anyone care to dig harder?)

(In reply to comment #12)
> Does anyone knows BuildId of 1.01b1?

Bug 530096 comment #10 indicates release on 2010-01-12, but I don't know the exact build ID.
Component: Message Reader UI → Lightning Only
Product: Thunderbird → Calendar
QA Contact: message-reader → lightning
Version: 3.0 → Lightning 1.0b1
(In reply to comment #14)

> At any rate, this does seem to be a Lightning bug (no pun intended), so moving.

FYI English is not my native language. So maybe I got it wrong.
By moving, do you mean that we should give up because it's Lightning bug?
If yes, where to report a bug to Philipp, core Lightning developper

BTW I think that Lightning is so close to TB that we should go on.

> (I have the vague feeling that this is a dup, but I'm not at all sure of that,
> and didn't find anything. Anyone care to dig harder?)

I found 1 bug that may be a duplicate:
https://bugzilla.mozilla.org/show_bug.cgi?id=540453
Is it the one you were looking for ?
(In reply to comment #15)
> FYI English is not my native language. So maybe I got it wrong.

Actually (like most people who mention that they speak English as a second language ;-)), your English seems just fine. And a lot of native speakers file bugs in the wrong place, including sometimes QA people, developers, and such-like for Mozilla. Not something to worry too much about.

> By moving, do you mean that we should give up because it's Lightning bug?

Not at all, I'm just putting it in its proper product (Calendar) and component (Lightning Only) so it can be worked on there; that's done now. (Lightning shares a Bugzilla installation with other Mozilla products, so it's pretty easy to move bugs around. And often necessary.)

> If yes, where to report a bug to Philipp, core Lightning developper

For future reference, right here:
https://bugzilla.mozilla.org/enter_bug.cgi?product=Calendar

> BTW I think that Lightning is so close to TB that we should go on.

Yes, and that's why I moved it to its proper component (this is also why they share a Bugzilla installation).

> I found 1 bug that may be a duplicate:
> https://bugzilla.mozilla.org/show_bug.cgi?id=540453
> Is it the one you were looking for ?

No; actually, I hadn't seen that one before. It looks like it's triggered differently, although Lightning does make an appearance. Thanks for looking, though. If there is a dup somewhere, I'm not seeing it....
Flags: blocking-calendar1.0?
Duplicate of this bug: 520391
Regression range:

works:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0pre Thunderbird/3.0.3
2008-10-08-09-comm-central

broken - Selection works but CTRL-C does not copy:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0pre Thunderbird/3.0.3
2008-10-09-05-comm-central

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-10-08+08%3A00%3A00&enddate=2008-10-09+06%3A00%3A00

Candidate: Bug 402365
I cannot find why this bug is not on trunk... but here is what I know.

The last comm-central build before comm-central disappeared for 3 months, and the first comm-central build after are listed below. The bug disappeared between them.

Also, all builds between were 1.9.1 and the bug still exists on 1.9.1. So I don't know why it is gone.


broken - selection works. CTRL-C doesn't:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0pre Thunderbird/3.0.3
2009-06-16-03-comm-central

works:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0pre Thunderbird/3.0.3
2009-11-11-05-comm-central
These builds (comments 18,19) were from the calendar nightlies as comment 12 suggested.
Please consider bug 520391, which was marked dup here. Some mail people saw that bug, others do not. It seemed to be OS-dependent, but may just as well have been triggered by Lightning.

Thus, when bisecting, you need to consider bug 489609 as mentioned there. It changed how text fields in the message header pane are displayed. It was commited to comm-central on 2009-10-26 07:13:17 PDT, see bug 489609 comment 63.

However, that alone doesn't seem to be the bug, as some (most?) people don't see this bug even with this change, as bug 520391 shows. So, it probably is an interaction between the "subject-wrap" change from bug 489609 with some  modification that Lightning does.

That means that bisecting probably won't help you find the bug. However, there shouldn't be much in Lightning which modifies or accesses the subject line of mails, so it shouldn't be that hard to find.

What would be needed from testers is to verify under which *conditions* the bug does occur and does not occur. Does it (bug 520391 and this bug) occur only when you have Lightning installed?
Just to be clear, as there are still questionmarks here:

Reproduced with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

1) I can't copy the subject line or the date via CMD+C when in the message pane or when the message is opened in a new Tab. When opened in a new window, CMD+C works.

2) Uninstalling the Lightning extension (and restarting TB) helps, I can now copy the subject line and the date via CMD+C in the message pane, when opened in a tab and when opened in a new window.

There are no errors in the error console logged when pressing CMD+C. Starting under GDB did not work ("Program exited with code 06.") ...so, any ideas how to debug this w/o gdb?
I can make accel-C or the copy menu work at various times. Here's the steps to repeat:

1) Open Calendar View
2) Select a calendar item
3) return to 3-pane window
4) select text in the header of an email

=> Copy is enabled.

If I then ensure no calendar items are selected, then copy is disabled.

I'm pretty sure this is Lightning's fault for altering the behaviour of cmd_copy:

http://hg.mozilla.org/comm-central/annotate/9e3c8ed5373b/calendar/base/content/calendar-common-sets.js#l248

That code isn't tab-aware which is where it falls down.

This means it blocks bug 527254, but I also thought there was another Lightning bug on picking up the code for the command controllers for tab specific items.
Blocks: 527254
Attached patch Incomplete fixSplinter Review
This fixes the cmd-c issue, but breaks the today pane.

From what I've worked out, calendarController gets installed into the entire window (in place of the Thunderbird one), and it gets called from the tab handlers (in messenger-overlay-sidebar.js).

As calendarController overrides some of the Thunderbird commands, Thunderbird doesn't get a look-in when deciding what to enable or not. Hence the breakage.

I think the only reason accel-c works in other areas, e.g. message pane, is because there's other controllers that get handled before the default controller.

As mentioned above the today pane is broken with this patch. I have a feeling this could probably be fixed by installing the calendarController as a controller for the today pane and not the whole window. I think this is what we do with the folder pane & message lists (which then get handled before the default controller...).
Duplicate of this bug: 544046
Since Bug 544046 (for copying the Subject) was marked a duplicate of this bug, could someone please edit the Subject line of this bug to include the term "Subject"? And since the Subject is more relevant than the date, "Subject" should appear first:

(Message header) Can't copy Subject and Date of message (CTRL+C)
Summary: (Message header) Can't copy date of message (CTRL+C) → (Message header) Can't copy date or subject of message (CTRL+C)
Will be fixed in command controller tracker bug (see depends)
Flags: blocking-calendar1.0?
Tried out 3.1 today, and I can now CMD+C again the subject fields in the message pane or when the message is opened in a new tab. Thanks!

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2pre Thunderbird/3.1
Running Thunderbird 3.1 with Lightning 1.0b2, Google Calendar 0.7, under Windows 7 64bits. 

The Ctrl+Copy problem in the headers seems to be fixed now. It works fine. Thanks.
I can confirm that now is WFM. It remains that when I select the date, the right button of the mouse not show "copy" item, but "custumize" (header toolbox).

Probably we can spin off this issue.
What patch a fixed the issue?

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.7pre) Gecko/20100629 Lightning/1.0b2 Lanikai/3.1.1pre ID:20100629034315
This bug was fixed by its dependent bug 527254. Its not marked fixed since the patch was only a hack. I'll close this bug when the final patch is in.
Duplicate of this bug: 622351
I added this to TB-keyboard-tracker bug because TB is affected by this bug, no matter if it's caused by Lightning or not.
See Also: → 540729
Can't copy message date yet in tb13, even without lightning :(
Thomas, that seems to be bug 541330.
Closing this bug in favor of bug 527254.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.