Started from pinned icon adds a new icon not showing running state

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: anttit, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre Firefox/3.5.3

When started from a pinned icon, Minefied is supposed to use it to show it's running state etc but since todays nightly it adds a new icon to taskbar. That new icon shows running state and "says Firefox" when left clicked. Maybe that is the reason it does not find that pinned icon?

Reproducible: Always

Steps to Reproduce:
1.Pin Minefied icon to taskbar
2.Start Minefied
3.Icon shows running state
Actual Results:  
A new icon is added like there is no pinned icon.  This new icon shows running state but breaks preview of tabs it seems.

Expected Results:  
Pinned icon shows running state and previews etc..

That new icon "says Firefox" when left clicked?
Minefied icon "says Minefield"

A typo somewhere?
(Reporter)

Updated

9 years ago
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
If I pin that new Icon (Which says Firefox): 
I can start Minefield with it, it shows running state, 
but preview from one page only (but many windows) but no jump list.

Older Icon (which says Minefield) shows jump list..

So a mix of names/ID's ? 

With 091006 nightly all works with that Minefield icon...
(Reporter)

Comment 2

9 years ago
Seems this identity crisis has been fixed in latest hourlies so it is in next nightly...  Sorry about bugspam!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.