Many RSS feeds do not display at all, some are broken with missing images, need to keep changing message body view

RESOLVED DUPLICATE of bug 491187

Status

MailNews Core
Feed Reader
--
major
RESOLVED DUPLICATE of bug 491187
9 years ago
6 years ago

People

(Reporter: Orest, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Variety of problems seeing RSS articles in Thunderbird 3.0 beta 4.

Some examples:

http://googlesystem.blogspot.com/
As "Simple HTML", articles display with broken image icons, okay but awkward to read as "Plain Text," and invisible as "Original HTML."

http://www.elearnspace.org/
Okay as "Simple HTML," tolerable as "Plain Text", invisible as "Original HTML."

http://www.cbc.ca/
Images are important for these news articles but they are invisible as "Orignal HTML."

http://feedproxy.google.com/uclick/pibgorn?format=xml
Even more so, images are important but invisible as "Original HTML."

All the above worked okay in TB2.


Reproducible: Always

Steps to Reproduce:
1. Subscribe to a feed such as http://feedproxy.google.com/uclick/pibgorn?format=xml
2. Connect and load latest articles.
3. Try to view and cycle through options under View > Message Body As 
Actual Results:  
Images are not visible at all. 

Expected Results:  
Images should be visible in "Original HTML" view.
Component: Message Reader UI → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: message-reader → feed.reader
Version: unspecified → 1.9.1 Branch
Whiteboard: dumpe
(Reporter)

Comment 1

9 years ago
Just upgraded to TB 3 (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091121 Lightning/1.0pre Thunderbird/3.0).  Problem still exists.
(Reporter)

Comment 2

9 years ago
Maybe related?: https://bugzilla.mozilla.org/show_bug.cgi?id=491187

Comment 3

8 years ago
In TB 3.0 and later, the
  View | Message Body As
menu changes when a feed item is selected, and that lets you change the global RSS-item display mode.

See bug 438429 comment 81.

Updated

8 years ago
Whiteboard: dumpe → dupeme

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491187

Updated

6 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.