Closed Bug 521156 Opened 10 years ago Closed 10 years ago

tests package only 160 bytes for universal mac builds since tracemonkey merge

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nthomas, Assigned: ted)

Details

Before:
OS X 10.5.2 mozilla-central build on 2009/10/06 22:48:52  
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1254894532.1254897535.32508.gz
producing a 9.6M firefox-3.7a1pre.en-US.mac.tests.tar.bz2

After:
OS X 10.5.2 mozilla-central build on 2009/10/07 00:29:46
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1254900586.1254904776.14592.gz
producing a 160B firefox-3.7a1pre.en-US.mac.tests.tar.bz2

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e2f0a8ec44c5&tochange=eb8a5ea7468c
which includes the jsreftest landing.

This a developer facing regression, because the we feed 
  OS X 10.5.2 mozilla-central build
  --> OS X 10.5.2 mozilla-central test opt mochitests
  --> OS X 10.5.2 mozilla-central test opt everythingelse
and those appear on tbpl. But we still have test coverage through
 OS X 10.5.2 mozilla-central unit test 
  --> OS X 10.5.2 mozilla-central test mochitests
  --> OS X 10.5.2 mozilla-central test everythingelse
because a Intel only build works fine. Win32, Linux are also OK.
Assignee: nobody → bclary
looks like it was js reftests
The OS X opt unittests are a little funny, because since bug 518641 landed, we use the universal binary machinery to build a universal test package.

I just found the problem as I was looking at this, it's just a bad merge. Compare the changes here:
http://hg.mozilla.org/mozilla-central/diff/07837dc569c6/testing/testsuite-targets.mk
vs. the merged results here:
http://hg.mozilla.org/mozilla-central/annotate/c08baee44cf4/testing/testsuite-targets.mk#l125
Assignee: bclary → ted.mielczarek
Pushed a bustage fix:
http://hg.mozilla.org/mozilla-central/rev/e36c57772b2e
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.