Last Comment Bug 521209 - Alt-S and alt-D access key twice in Options/Display
: Alt-S and alt-D access key twice in Options/Display
Status: VERIFIED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86 Windows XP
: -- minor (vote)
: Thunderbird 11.0
Assigned To: :aceman
:
Mentors:
: 521208 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-08 04:33 PDT by Onno Ekker [:nONoNonO UTC+1]
Modified: 2012-09-25 14:09 PDT (History)
7 users (show)
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
options display accesskey (21.40 KB, image/png)
2011-11-13 10:18 PST, Wayne Mery (:wsmwk, NI for questions)
no flags Details
patch, changing accesskeys per comment 10 (2.10 KB, patch)
2011-11-25 12:06 PST, :aceman
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review

Description Onno Ekker [:nONoNonO UTC+1] 2009-10-08 04:33:02 PDT
The Tools->Options tab Display now includes Fonts. Here "_S_ize" was added, but size was already there for quoted plain text messages. As a result Alt-S access key doesn't work.
Comment 1 Onno Ekker [:nONoNonO UTC+1] 2009-10-08 04:36:32 PDT
It's called Display Pane, tab is Formatting...
Comment 2 Nikolay Shopik 2009-10-08 04:45:23 PDT
confirm
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091007 Shredder/3.0pre
Comment 3 Wayne Mery (:wsmwk, NI for questions) 2009-12-09 19:44:55 PST
there's also two Ds
Comment 4 :aceman 2011-11-13 08:38:36 PST
I can do this. So what is the proposal?
Default _F_ont ? Second occurence of size -> Si_z_e ?

Also, shouldn't "Tags can be used to categorize and prioritize your messages." have an accesskey? It would focus the tag list.

Removing wanted-tb3 flag, it is outdated.
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2011-11-13 10:18:57 PST
Created attachment 574164 [details]
options display accesskey

to me,what makes the most sense is something approximate to what is shown in the screen shot
Comment 6 :aceman 2011-11-13 10:28:29 PST
Bwinton, would you accept the proposal in the screenshot?
Comment 7 Blake Winton (:bwinton) (:☕️) 2011-11-25 06:50:26 PST
Wayne, why do you want to change Style to _S_, instead of just leaving it as _y_, and letting the second Size keep the _S_?
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2011-11-25 07:38:25 PST
Of all the options shown, I'd think the most used would be Font and Size at the top. SO thinking on it more, my original rationale for attachment 574164 [details] isn't convincing.  

How about making the second Size = _z_, keeping first Size as _S_?
Comment 9 :aceman 2011-11-25 07:47:37 PST
That is my comment 4 :)
Comment 10 Blake Winton (:bwinton) (:☕️) 2011-11-25 07:57:13 PST
Hmm, having f be the key for "Default font" would lead to "De_f_ault Font".  :(

Okay, so ui-r=me for keys in the following order (from top-left)
_D_efault Font, _S_ize,
Display _e_moticons as graphics,
St_y_le, Si_z_e

does that work for everyone?
Comment 11 :aceman 2011-11-25 08:03:33 PST
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #10)
> Hmm, having f be the key for "Default font" would lead to "De_f_ault Font". 
Ah, yes.

> does that work for everyone?
No problem with me, I do not use the keys. I'll patch whatever you decide.
Comment 12 Wayne Mery (:wsmwk, NI for questions) 2011-11-25 08:06:51 PST
I propose dumping a can of alphabet soup and see what floats to the top :)

seriously though, I'm cool with comment 10
Comment 13 :aceman 2011-11-25 12:06:06 PST
Created attachment 576980 [details] [diff] [review]
patch, changing accesskeys per comment 10
Comment 14 Blake Winton (:bwinton) (:☕️) 2011-11-25 12:12:06 PST
Comment on attachment 576980 [details] [diff] [review]
patch, changing accesskeys per comment 10

Review of attachment 576980 [details] [diff] [review]:
-----------------------------------------------------------------

WFM!
Comment 15 :aceman 2011-12-01 03:54:51 PST
Can you also give review?
Comment 16 Blake Winton (:bwinton) (:☕️) 2011-12-02 14:03:58 PST
Comment on attachment 576980 [details] [diff] [review]
patch, changing accesskeys per comment 10

Review of attachment 576980 [details] [diff] [review]:
-----------------------------------------------------------------

Okay, fine, r=me, too.

Later,
Blake.
Comment 17 Mark Banner (:standard8) 2011-12-09 05:59:49 PST
Checked in: http://hg.mozilla.org/comm-central/rev/a52dab6b64f4
Comment 18 Javi Rueda 2012-09-25 14:09:25 PDT
*** Bug 521208 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.