Folder pane not repainted when jumping to new mail causes an account to expand

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: john, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When using the space or 'N' keys to jump to next unread message, folder pane is not always repainted properly

Reproducible: Sometimes

Steps to Reproduce:
1. Select All Folders view
2. Ensure that an account other than the default has unread messages in a folder other than the first; minimise this account 
3. Display a message in a different account (preferably such that there are no intervening unread messages)
4. Press 'N' or 'space' to go to the next unread message


Actual Results:  
The account's folder tree is expanded but only the folder with unread messages is painted (see attached screenshot)

Expected Results:  
All folders should be painted

I was only able to reproduce this when the unread message was in a *news:* account, and only immediately after starting Thunderbird.
(Reporter)

Comment 1

9 years ago
Created attachment 405262 [details]
Screenshot showing problem
Confirmed here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091008 Lightning/1.0pre Shredder/3.0pre ID:20091008033625
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

6 years ago
is this still seen in recent versions?
Flags: needinfo?
(Reporter)

Comment 4

6 years ago
I can't reproduce this using the steps I outlined in the initial bug, nor have I observed the symptoms for some time.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.