updater.exe fail with manually launch.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: yann_riviere, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Apply this procedure : https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file

The procedure to manually update firefox finish always with a "failed : 6"  in the update status.


Reproducible: Always

Steps to Reproduce:
1.Apply this procedure : https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file

At least for Windows:

   1. create a directory outside the firefox directory to be updated, e.g. %TEMP%\firefox-update
   2. copy updater.exe and updater.ini from your current installation to that directory.
   3. download appropriate .mar file and put it into the directory you created. Check ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-3.5/update/
   4. Important: cd to the firefox program directory, e.g. cd %programfiles%\Mozilla Firefox. Running the update from within another directory will fail.
   5. echo "pending" > %TEMP%\firefox-update\update.status
   6. Run %TEMP%\firefox-update\updater.exe %TEMP%\firefox-update\ 0 
Actual Results:  
update.status : failed: 6
update.log : failed: 6
calling QuitProgressUI


Expected Results:  
Firefox updated from 3.5.2 to 3.5.3

I have followed exactly the procedure and firefox is not updated.
3 days passed to find the issue.....

We want to update firefox by this way to control which version is deployed, because we have SSO engine installed and when firefox have updated him automatically from 3.0.6 to 3.0.7, the SSO have been broken.

Thanks a lot !
Component: Security → Application Update
Product: Firefox → Toolkit
QA Contact: firefox → application.update
Version: unspecified → 1.9.1 Branch
What happens when you use real paths instead of paths with %TEMP%
(Reporter)

Comment 2

9 years ago
Hello,

I have tried with the %TEMP% variable and the real path. I have exacly the same issue.

Thanks
I've manually updated and we have tests that do this as well. Firefox can't be running during the update but I suspect it isn't. You don't need to copy the updater.ini.

Looking at the wiki it looks like someone has made it rather complicated. You can do the following from the directory where you would like to update Firefox
copy the updater.exe and the update.mar into a new directory.
cd into the directory you would like to update
launch the updater located in the new directory
(Reporter)

Comment 4

9 years ago
Hi,
I have tested on a directory where there is updater.exe and update.mar.
I have launched updater.exe from this directory.
I have launched updater.exe updater.mar.

Without success..

Please find below result of the command lines..

Thanks !

E:\updates>dir
 Volume in drive E is DATA
 Volume Serial Number is E882-FF99

 Directory of E:\updates

13/10/2009  17:55    <DIR>          .
13/10/2009  17:55    <DIR>          ..
13/10/2009  17:52         2,531,877 update.mar
28/04/2009  19:10           242,168 updater.exe
               2 File(s)      2,774,045 bytes
               2 Dir(s)   7,368,978,432 bytes free

E:\updates>updater.exe

E:\updates>updater.exe update.mar

E:\updates>dir
 Volume in drive E is DATA
 Volume Serial Number is E882-FF99

 Directory of E:\updates

13/10/2009  17:55    <DIR>          .
13/10/2009  17:55    <DIR>          ..
13/10/2009  17:52         2,531,877 update.mar
28/04/2009  19:10           242,168 updater.exe
               2 File(s)      2,774,045 bytes
               2 Dir(s)   7,368,912,896 bytes free

E:\updates>
I've updated the wiki page to cover most of the issues that can occur when trying to manually update. Please try these new instructions

added url for the instructions
https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file
Another person has verified the documentation works on Windows and I've also verified it. Resolving WFM. If you still have problems please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

9 years ago
Hello !

Yes, it is working.
But, it seems that this way, the registry is not updated nor the Config Panel.
I can see that HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firefox registry entry is not updated....
Is it this way the updater.exe must act ?

This is important for us as we check what version of Firefox is installed via the users desktop registries.

Thanks.
Steps 9 - 12 on the page updated the registry entries under HKLM for me.
(Reporter)

Comment 9

9 years ago
Oh Yeah :)
For me too !

Sorry to have disturbed you ! I have not applied the steps 9-12 and this is the cause of my issues...

All is working fine !

Thank you very much.
(Reporter)

Comment 10

9 years ago
Hi !

Do you think it is possible to block the access to Firefox.exe while the updater.exe is running?

I'm afraid that a user launch firefox while an update is running.

Thanks !
We do that as of Firefox 3.6
You need to log in before you can comment on or make changes to this bug.