Midas - delete key deletes an extra space

RESOLVED WORKSFORME

Status

()

Core
Editor
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Marcos Almeida, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.25 Safari/532.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

When you delete the only character in a on-character-word followed by a space, the space gets deleted too.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.mozilla.org/editor/midasdemo/
2. Type "a b c"
3. Place the cursor immediately to the left of the "b"
4. Press the delete key
 --> Both the "b" and the following space are deleted. Only the "b" should have been deleted.
5. Press the delete key again
 --> Nothing happens, but the user would expect "c" to be deleted now.



This bug does not happen in Firefox 3.0 .

This affects Google properties.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20091005 Shiretoko/3.5.4pre

This works fine for me. Can this be reproduced in safe-mode / with a new profile?

http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

If so, can you please provide more information to reproduce the bug?
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

8 years ago
Yes it reproduces in safe mode. I had just installed a fresh 3.5.3 to reproduce it so it is with a new profile. Also just got it to reproduce on 3.5.3 on the mac (you have to press fn+delete).

The initial html before pressing delete is "a b c<br>". If you look at the resulting html in 3.0, the correct result is "a&nbsp; c<br>". In 3.5.3, the resulting html is just "a c<br>". Maybe the new code is "forgetting" to convert the first space into an nbsp, and then when it sees two adjoining soft spaces it merges them?
With the latest Firefox 3.5 I get the result: a&nbsp; c <br>
after deleting the b .
The Firefox profile is not in the installation directory. Uninstalling/reinstalling Firefox will leave the profile untouched.
The latest Firefox 3.5 (Shiretoko) test nightlies can be downloaded here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.1/
(Reporter)

Comment 4

8 years ago
OK I see it as you did, fixed on 3.5.4pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Great! It's WORKSFORME because the code that fixed it is unknown.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.