Html rendering sometimes hangs when a java applet is embedded on the website

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: axianx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120713])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

When visiting websites with java applets ocassionally only the applet GUI is displayed and the html area remains blank.
After clicking on applet buttons or entering some tesx after a few seconds the surrounding html would be displayed correctly.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to a website with an applet
2.
3.
Actual Results:  
Sometimes only the applet GUI is displayed, and the html area remains blank.

Expected Results:  
Both, applet and surrounding html are displayed.

Java 6 U 16
The problem is reproducible with the classic as well as the next-generation plugin.
(Reporter)

Comment 1

8 years ago
Created attachment 405426 [details]
expected result
(Reporter)

Comment 2

8 years ago
Created attachment 405428 [details]
error condition
(Reporter)

Comment 3

8 years ago
This regression should be fixed in 3.6
Flags: blocking-firefox3.6?
--> Core

Axianx: in what versions of Firefox are you seeing this? And do you have a test URL or testcase that we can use to find a regression range?
Component: General → Plug-ins
Flags: blocking-firefox3.6?
Product: Firefox → Core
QA Contact: general → plugins
Flags: blocking1.9.2?
(Reporter)

Comment 5

8 years ago
@Mike:
Firefox 3.5.5
Go to https://www.elsteronline.de/eportal/Authentisiere.tax, select the radiobutton "Software-Zert." and click "Login".
This is the site where I took the sceenshot
https://bug521389.bugzilla.mozilla.org/attachment.cgi?id=405428
WFM on OSX and win32 using a latest Firefox 3.6 nightly, though in Windows the applet never fully initialized due to a NullPointerException in the code (ran fine on OSX, bizarrely)

We'll need a confirmation before we can block on this.
Flags: blocking1.9.2?
Keywords: qawanted
As per comment 5, might be 3.5.x only; QA, can we get a confirmation?
[testday-20120713]

I cannot reproduce this on the latest Nightly.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Windows 7 x64

Steps Taken
1. Go to https://www.elsteronline.de/eportal/Authentisiere.tax
2. Click on Software-Zertifikat radio button
3. Click Login
4. Java applet loads as expected, and html area remains visible as expected
Whiteboard: [testday-20120713]
Please reopen this bug if it's reproducible in the latest Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.