Weave cannot authenticate via default OpenID

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: dma_k, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: 

When trying to login to http://www.myexperiment.org/ with Weave 0.6 or Weave 0.7 the following error occurs:

Verification of "https://services.mozilla.com/openid/dma_k" failed.

When config setting "extensions.weave.openId.custom" to another OpenId e.g. to "http://dma-k.livejournal.com" authentication with Weave works fine.

Reproducible: Always

Comment 2

8 years ago
Is this still a problem?  And is it a problem with the client, or the OpenID service on the Weave servers?

(the client doesn't support OpenID anymore, but I believe we keep the service running for current users)
(Reporter)

Comment 3

8 years ago
Well, I cannot check, because I do not see the button "Login with Weave", which was shown instead of normal "Login". If this feature is not included in weave anymore - this but is irrelevant then.

Comment 4

8 years ago
I wish we had open id on the wiki

Comment 5

8 years ago
(In reply to comment #3)
> Well, I cannot check, because I do not see the button "Login with Weave", which
> was shown instead of normal "Login". If this feature is not included in weave
> anymore - this but is irrelevant then.

The feature was removed from Weave and Account Manager (we may add OpenID support to Account Manager in the future again), but we left the service running so that users could continue to use existing accounts by using Account Manager 0.0.2 which contained the Signin with Weave feature.

So anyway, we don't plan to fix this bug in current versions, marking as wontfix.

(In reply to comment #4)
> I wish we had open id on the wiki

Not related to this bug, file a bug on the wiki component.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Component: Identity → Identity
Product: Mozilla Services → Mozilla Labs
Target Milestone: --- → --
You need to log in before you can comment on or make changes to this bug.