In Firefox 3.6+, Last.fm navbar wraps and shows scrollbars when clicked/focused [due to use of unsupported -moz-outline property]

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(2 attachments)

STEPS TO REPRODUCE:
 1. Visit http://www.last.fm/
 2a. Press the "tab" key until an item in the header is focused
     ("Music | Radio | Events | Videos | Charts | Community")
 ALTERNATELY:
 2b. Click any of the links in the header.

ACTUAL RESULTS: The last entry in the header, "Community", wraps to its own line, and a scrollbox appears around the header. (with grayed-out scrollbars)

BROKEN:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b1pre) Gecko/20091009 Namoroka/3.6b1pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091009 Minefield/3.7a1pre

WORKING:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091007 Ubuntu/9.10 (karmic) Firefox/3.5.3

Requesting blocking1.9.2, since this is a layout regression with respect to Firefox 3.5
Flags: blocking1.9.2?
In Firefox 3.5, it looks like we actually don't show a dotted-outline around last.fm's header-box links, when they're focused.  (I can tell they're focused because the status bar changes to show the link target, though)

In Firefox 3.6 and mozilla-central, we *do* show a dotted outline.
Created attachment 405588 [details]
screenshot: normal last.fm
Created attachment 405590 [details]
screenshot: broken last.fm ("Music" selected)

These screenshots were taken using the Firefox 3.6 nightly mentioned in comment 0.
Reproduced on OSX (latest 3.6 nightly) & Windows (trunk built yesterday).
OS: Linux → All
Regression range:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081207 Minefield/3.2a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/bc71507c7ccb

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081208 Minefield/3.2a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/f03bb4a3ce53

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc71507c7ccb&tochange=f03bb4a3ce53

I suspect bug 458588 / changeset e731e7196ba9  ("drop -moz-outline* aliases.")
It looks like last.fm does currently use "-moz-outline" to remove outlines from links:
 http://cdn.last.fm/css/release-lastfm/142159/master.css

> a {
>    color: #0187c5;
>    text-decoration: none;
>    -moz-outline: none;
> }

My guess is that this would be fixed if last.fm just switched that to "outline: none"
Adding "a:focus {  outline: none; }" for last.fm in the Stylish addon appears to fix this.
Blocks: 458588
(In reply to comment #5)
> My guess is that this would be fixed if last.fm just switched that to "outline:
> none"

Confirmed -- in a saved copy of the last.fm front-page, I can fix bug this by simply removing "-moz-" from that one line of the "a" style rule in last.fm's "master.css" file.

(When I'm using Stylish, the ":focus" is needed for some reason, per comment 6.  But that's not needed when I'm editing the actual CSS used by the web page.)

I'm switching this to an Tech Evangelism bug. Last.fm's "contact us" page seems to direct all web site issues to their "Web Site Support" forum ( http://www.last.fm/forum/21713/overview ) so I'll start by creating a thread for this issue there.
Assignee: nobody → english-us
Component: Layout → English US
Flags: blocking1.9.2?
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified
Filed this thread in last.fm Web Site Support forum:
 http://www.last.fm/forum/21713/_/572338
Summary: Last.fm header wraps and shows scrollbars when its links are focused → Last.fm header wraps and shows scrollbars when its links are clicked/focused [due to use of unsupported -moz-outline property]
Summary: Last.fm header wraps and shows scrollbars when its links are clicked/focused [due to use of unsupported -moz-outline property] → In Firefox 3.6+, Last.fm navbar wraps and shows scrollbars when clicked/focused [due to use of unsupported -moz-outline property]
Depends on: 517071
Someone posted on the last.fm forum to say that they've fixed this and it'll go live tomorrow.  Yay!
http://www.last.fm/forum/21713/_/572338/1#f10841963

(I'll close this bug tomorrow, once I've verified that it's fixed.)
I've confirmed that this is now fixed (on last.fm's side).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.