Viewing messages/user interaction should take precedence over feed updating

RESOLVED DUPLICATE of bug 711173

Status

RESOLVED DUPLICATE of bug 711173
9 years ago
7 years ago

People

(Reporter: sirolly, Unassigned)

Tracking

({perf})

1.9.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When subscribed to dozens of feeds, and the time to update those feeds arrives, Thunderbird appears to queue up all of the feeds to be updated and filtered at that time, and place most user interaction at the "back of the line" in terms of priority.

For example, while a large number of feeds are updating, and the user selects a message from any account or folder, it may take quite a while for the message contents to display in the reading pane. If the user double-clicks the message, it may take quite a while for a message window to open, and a longer delay still for the window to display the message (in some cases, Thunderbird even appears to "forget" that a message should be displayed in the window). Clicking on menus, menu buttons or right-clicking on items can result in a long delay before the desired menu is displayed, or a menu choice can be selected.

On the bright side, while a large number of feeds are updating, the interface updates quickly when switching folders, and other running applications remain responsive.

Feed updating and filtering should occur more as though its in a background thread, with interruptions from user interaction always taking precedence. Updating and filtering feeds should take care not to saturate available network requests, disk access to e-mail stores or available processor resources, at the expense of viewing messages or other user interaction.

Reproducible: Always

Steps to Reproduce:
1. Set up feed folder with 100+ feeds, set to update at a reasonable time interval.
2. When the update time interval occurs, and as feeds appear to be updating, attempt to view e-mail messages, or access application menus, button menus or second button context menus. 
3. Time how long it takes for the desired messages or menus to be displayed.
Actual Results:  
The message pane may not update to display the selected for 20 seconds or more. In the meantime, Thunderbird continues updating the counts of unread messages for feeds that are being checked.

A new message window may take 20 seconds to open, and then remain blank for another minute before displaying the message -- or fail to ever display the message. In the meantime, Thunderbird continues updating the counts of unread messages for feeds that are being checked.

Menus may take 15 seconds to appear after clicking. In the meantime, Thunderbird continues updating the counts of unread messages for feeds that are being checked.

Expected Results:  
Thunderbird should display a selected message or the desired menu almost immediately, within a second or two, even when the application is busy updating and filtering feeds. User interaction should immediately "jump to the front of the line" even when the application is busy updating and filtering feeds.
Component: Mail Window Front End → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: front-end → feed.reader
Version: unspecified → 1.9.1 Branch

Updated

7 years ago
Keywords: perf
Summary: Viewing messages/user interaction should take precedence over feed updating and filtering → Viewing messages/user interaction should take precedence over feed updating

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711173
You need to log in before you can comment on or make changes to this bug.