Cannot create "Blogs & News Feed" or "Newsgroup" account

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Account Manager
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: ssitter, Assigned: Bienvenu)

Tracking

({regression})

Thunderbird 3.0rc1
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5pre) Gecko/20091010 Shredder/3.0pre

Steps to Reproduce:
1. Start Shredder with new profile
2. Cancel the Mail Account Setup dialog
3. Cancel the System Integration dialog
4. Open menu File > New > Other Accounts...
5. Select "Blogs & News Feed" or "Newsgroup" account and click on Next

Actual results:
Nothing happens. Only canceling the Account Wizard is possible. No messages in Error Console. 

Expected results:
Account creation continues.
(Reporter)

Comment 1

9 years ago
Works in Thunderbird 3.0pre (BuildID: 20091007032014)
Fails in Thunderbird 3.0pre (BuildID: 20091008033625)
Blocks: 515479
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3+
Keywords: regression
Duplicate of this bug: 521572

Updated

9 years ago
Severity: normal → major
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Comment 3

9 years ago
yikes. Nothing on the error console that I can see...
Assignee: nobody → bienvenu
(Assignee)

Comment 4

9 years ago
Created attachment 405689 [details] [diff] [review]
possible fix

There are a lot of ways this could be fixed - I wanted to avoid the #ifdef solution, so I went with the try catch, but I'm open to suggestions.
Attachment #405689 - Flags: review?(philringnalda)
Created attachment 405702 [details] [diff] [review]
Less

I'm getting into my release mode, wanting to see as few characters as possible changed :)

getElementById() is perfectly happy to not find anything, so there's no need to try/catch, as long as we null-check before we use it.
Attachment #405702 - Flags: review?(bienvenu)
(Assignee)

Updated

9 years ago
Attachment #405702 - Flags: superreview+
Attachment #405702 - Flags: review?(bienvenu)
Attachment #405702 - Flags: review+
(Assignee)

Comment 6

9 years ago
Comment on attachment 405702 [details] [diff] [review]
Less

cool, thx, Phil. r/sr/a=me
Attachment #405689 - Attachment is obsolete: true
Attachment #405689 - Flags: review?(philringnalda)
http://hg.mozilla.org/comm-central/rev/d2eb1d85a95b
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
You need to log in before you can comment on or make changes to this bug.