Closed Bug 521595 Opened 11 years ago Closed 11 years ago

Session restore no longer works after a crash or when you choose save & quit.

Categories

(Firefox :: Session Restore, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 522545

People

(Reporter: geeknik, Assigned: zpao)

Details

(Keywords: hang, regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091010 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091010 Minefield/3.7a1pre

Just noticed this after I applied the update for the 10 October nightly build. When Minefield restarted, all of my tabs opened with the correct URLs, but none of the tabs actually loaded anything. They were just a blank white page. After Minefield crashed a little while later and the crash reporter restarted the browser, the same thing happened. All of my tabs were opened, but nothing was loading in them.  The title of the tabs says Loading... but there is not loading activity. Also when I hover over them in the Windows 7 taskbar, they just show up as a blank white box.

Reproducible: Always
Flags: blocking-firefox3.6?
Keywords: hang, regression
Version: unspecified → Trunk
You might be seeing 3 things: A the executeCrash which crashes on startup after a crash like B, B the session restore Crash issue, and C an edge case side bug for Win7 Taskbar previews.

The second is probably just a dupe of bug 497730 and the third is probably just an edge case issue while the browser is loading data for bug 474056.
Well, I've noticed now that session restore isn't even loading my tabs. It's loading tabs from the 1st crash that happened after the update to 10 October build. Weird.
i can't reproduce in the latest nightly. reporter, are you seeing this every time, or intermittently? can you please try with a new profile and provide a concise set of steps to reproduce?
This disappeared after I upgraded to the 11 October build and is not present in the 12 October build either.
This behavior has came back for me on the 15 October build of 3.7a1pre. After a crash earlier on reddit.com, when the session restore restarted Minefield, it re-opened 4 tabs, but didn't load them. I had to manually go to each tab, click on the url and hit enter to get the tabs to load the pages.
Brian, you may be seeing bug 522545. It seems to happen when the crash happens immediately after opening a new page or new tab. I should have a fix there and hopefully that fixes it.
Depends on: 522545
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Resolution: --- → DUPLICATE
Duplicate of bug: 522545
Paul - going to mark this as assigned to you since no blocker should be unowned, and you own the bug this has been dup'd against. Let me know if you disagree?
Assignee: nobody → paul
No longer depends on: 522545
Flags: blocking-firefox3.6+
You need to log in before you can comment on or make changes to this bug.