Thunderbird send scrambles emails with inline JPEG images.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: res06rdr, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-03-15], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; msn OptimizedIE8;ENUS; MSN 9.0;MSN 9.1;MSN 9.6; MSNbVZ02; MSNmen-us; MSNcOTH)
Build Identifier: version 2.0.0.23 (20090812)

1. Although Firefox is my default browser, Mozilla Help opens MSN Explorer to display web pages.

2. Whenever I include a JPEG Image inline, and send the email the message is received as a string of hexadecimal characters, the subject is blanked, and the adressee list changed to undisclosed recipients.

3. The program can receive emails with JPEG Images inline.

Reproducible: Always

Steps to Reproduce:
1. open Thunderbird.
2. write email, copy JPEG image inline.
3. specify addressee
4. add subject
5. click send
Actual Results:  
1. email appears in Thunderbird copy folder as composed
2. email appears in recipient's email inbox with addressee changed to; Unspecified Recipients.
3. email subject field is blank
4. email text appears as string of hexadecimal characters.  

Expected Results:  
I expected email would be received as composed.
Computer functioned normally.
Text only email is transmitted as composed
All emails sent in HTML, embedded images permitted.


Thunderbird receives email with embedded JPEG images as composed.
Although Firefox is my default browser, Thunderbird opens instead MSN Messenger to dispay web pages.
Default theme.
No indication of computer malfunction. No stack trace generated.
No crash.
Thunderbird contiues to operate, sending text only emails as composed, and sending emails with images as hex strings.
Does it go away if you delete mimetypes.rdf file in your profile ?
Component: General → OS Integration
QA Contact: general → os-integration
Version: unspecified → 2.0
(Reporter)

Comment 2

9 years ago
I found the files:

 ...\program files\Mozilla Thunderbird\defaults\profile Type: RDF file Modified 8/12/2009

 ...\documents and settings\Robert Palmer\Application Data\Thunderbird\Profile\o6uay2j9.default Modified 2/25/2009

and deleted them.

I tried to then open MSN mail account to send test document from Thunderbird to MSN mail to conduct the test, and Windows could not find msn.exe

I'm not sure how deleting the above files would "lose" msn.ese, as I have not lost it before in eight years. So I will try to recover MSN by restoring files from Trash, or reinstalling MSN if necessary.

Is there A way that I can try your test without losing MSN, or was this a coincidence?
(Reporter)

Comment 3

9 years ago
As a test I could create a simple email with embedded JPEG image in MSN mail, and sent it to you, and my Thunderbird account. Up to now Thunderbird has received these messages in tact. I could then forward the email received by Thunderbird to you. In cases before this message will be received with subject blank, recipients changed to undefined recipients, and text messge with embedded JPEG image replaced by Hex stream
(In reply to comment #2)

> Is there A way that I can try your test without losing MSN, or was this a
> coincidence?

coincidence .....


(In reply to comment #3)
> As a test I could create a simple email with embedded JPEG image in MSN mail,
> and sent it to you, and my Thunderbird account. Up to now Thunderbird has
> received these messages in tact. I could then forward the email received by
> Thunderbird to you. In cases before this message will be received with subject
> blank, recipients changed to undefined recipients, and text messge with
> embedded JPEG image replaced by Hex stream

Yep That's a good idea. Please proceed. and put the bug number somewhere in your email so I can reconnect the dots when I get the email.
(Reporter)

Comment 5

9 years ago
1. You are right about MSN. A problem was encountered by a previous user. I was able to restore it from Control panel.

2. After all this problem has seemed to have disappeared, maybe it was moving to trash and restoring them that corrected a glitch.

3. You can mark this closed, as I am pretty sure problem no longer exists. If it recurs, I will reference problem number.

4. Thanks for your help. Your suggestion provided remedy.
WFM per comment 5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

9 years ago
This bug has returned after I tried to send a bmp file inline. It was a Screen shot generated by keys ALT + Screenshot.

This happened after I had installed Thunderbird 2.0.0.23 and FireFox 3.5.3.

The email was corrupted blanking "Subject" and replacing "To" list with undisclosed recipients, and replacing message with a string of uppercase and lowercase letters and some + characters.

Although Firefox remained default browser according to "Check Now", Thunderbird in fact selects second browser MSN Explorer.

Status is now: RETURNED

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

9 years ago
This problem with sending emails containing JPEG or BMP files has only appeared in the last two months.

I copied an email that Thunderbird scrambled from the original Sent folder copy, and pasted it without alteration into an MSN Mail write window, and sent it without problem.

Is it possible to install a version of Thunderbird created prior to 1 July 2009? That would solve my problem.

Also observe that Thunderbird voids status of Firefox as default browser, but Windows does not - Firefox remains default browser for Windows, but not for Thunderbird.
(Reporter)

Comment 9

9 years ago
email 1:
 I originally missed your comment at the bottom:

>>Yep That's a good idea. Please proceed. and put the bug number somewhere in your email so I can reconnect the dots when I get the email.<<

The problem persists, so I will forward this email a second time with a JPEG image inserted. Thunderbird also destroys a message with a BMP image included, eg a Print Screen Image.

Ref: Re: [Bug 521611] Thunderbird send scrambles emails with inline JPEG images.

---------------------------------------------------------------------------------------------------------

bugzilla-daemon@mozilla.org wrote:
> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=521611
>
>
>
>
>
> --- Comment #4 from Ludovic Hirlimann (:_Tsk_) <ludovic@mozillamessaging.com>  2009-10-13 01:07:18 PDT ---
> (In reply to comment #2)
>
>   
>> Is there A way that I can try your test without losing MSN, or was this a
>> coincidence?
>>     
>
> coincidence .....
>
>
> (In reply to comment #3)
>   
>> As a test I could create a simple email with embedded JPEG image in MSN mail,
>> and sent it to you, and my Thunderbird account. Up to now Thunderbird has
>> received these messages in tact. I could then forward the email received by
>> Thunderbird to you. In cases before this message will be received with subject
>> blank, recipients changed to undefined recipients, and text messge with
>> embedded JPEG image replaced by Hex stream
>>     
>
> Yep That's a good idea. Please proceed. and put the bug number somewhere in
> your email so I can reconnect the dots when I get the email.
>
>   
email2:
 --------------------------------------------------------------------------------
JPEG Image included following>

>>Image: http://www.dpfwiw.com/images/jpeg_artifacts.jpg was in original email but cannot be reproduced here.<<

                                                                         




--------------------------------------------------------------------------------
I originally missed your comment at the bottom:

>>Yep That's a good idea. Please proceed. and put the bug number somewhere in your email so I can reconnect the dots when I get the email.<<

The problem persists, so I will forward this email a second time with a JPEG image inserted. Thunderbird also destroys a message with a BMP image included, eg a Print Screen Image.

Ref: Re: [Bug 521611] Thunderbird send scrambles emails with inline JPEG images.

---------------------------------------------------------------------------------------------------------

bugzilla-daemon@mozilla.org wrote:
> Do not reply to this email.  You can add comments to this bug at
> https://bugzilla.mozilla.org/show_bug.cgi?id=521611
>
>
>
>
>
> --- Comment #4 from Ludovic Hirlimann (:_Tsk_) <ludovic@mozillamessaging.com>  2009-10-13 01:07:18 PDT ---
> (In reply to comment #2)
>
>   
>> Is there A way that I can try your test without losing MSN, or was this a
>> coincidence?
>>     
>
> coincidence .....
>
>
> (In reply to comment #3)
>   
>> As a test I could create a simple email with embedded JPEG image in MSN mail,
>> and sent it to you, and my Thunderbird account. Up to now Thunderbird has
>> received these messages in tact. I could then forward the email received by
>> Thunderbird to you. In cases before this message will be received with subject
>> blank, recipients changed to undefined recipients, and text messge with
>> embedded JPEG image replaced by Hex stream
>>     
>
> Yep That's a good idea. Please proceed. and put the bug number somewhere in
> your email so I can reconnect the dots when I get the email.
>
>
The second email I recived contained the image and looked ok.
From private email :

You may want to close the bug report, and if the problem recurs I can add comment. Since the tb sent copy is literally in tact I could forward it to you as test case 1, and the same message with JPEG image replaced by its url as Test case 2.

What basically happens is that:
1.The Subject entry is blanked
2. The addressee list is replaced by Undisclosed Recipients.
3. The message text is replaced by a string of uppercase and lowercase letters, plus signs, and maybe a few other symbols. This list is either long, or short (maybe truncated, or not). It is not hex, as I first reported, but more than 16bit characters.
4. Assuming the message is transmitted as a sequential string, the damage is not subsequent to encountering the JPEG, but reaches back to the header contents.


Note for robert - we usually use the website to communicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

9 years ago
Problem has returned. Thunderbird selected MSN Explorer instead of FireFox as browser. FireFox Character encoding remained Unicode UTF-8.

Paste of Message Sent:

Subject:  Re: Scye bearing 
From:     Robert Palmer <res06rdr@gte.net>
Reply to: res06rdr@gte.net
Date:     11/11/2009 11:40 PM
To:       <Brett Gooden <bagooden@bigpond.net.au>
Bcc:      Robert Palmer <palmerrh@msn.com>
X-Mozilla-Status: 0001
X-Mozilla-Status2:00800000
Message-ID: <4AFBBBF7.5020208@gte.net>
Organization: Kanga Technical Services
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
References:  <27FDB6C2-C5F8-4036-AAD8-6A19DB96F8C9@bigpond.net.au>
In-Reply-To: <27FDB6C2-C5F8-4036-AAD8-6A19DB96F8C9@bigpond.net.au>
Content-Type: multipart/related; boundary="------------000302070301020706060601"
 


Well you are talking about the HUT. Scye bearings were used in  the space suits where  the astronauts  have to move in space. A presurized suit is fairly  rigid, so that one could not move body parts with respect to each other. The  Scye bearings allow  movement. As they  are  associated with injury, all or nearly all Scye bearings have been removed from modern suits.

Actually, it is a tailoring term, and the cut of one's jib depends on tsize of the shoulder scye, etc.
Q: How should I take my armscye measurement?
A: In order to take your armscye measurement, you must wrap the measuring tape over the top of your shoulder and around under your armpit, as pictured.

[Image] [Image] Note: this space won't let me paste actual images, but I can email a paste of original the message to Ludovic if requested (via MSN).


Bob

Brett Gooden wrote:
> Hi Bob,
> I' working on understanding the Shuttle spacesuit. According to the text I've downloaded from a nasa site: "The arm interfaces with the hard upper torso assembly by a ring that retains the arm scye bearing in the hard upper torso opening."
> Can you tell me what a scye bearing is please?
> Brett 

Paste of Message received:

X-Message-Delivery: Vj0xLjE7dXM9MDtsPTE7YT0xO0Q9MTtTQ0w9MA==
X-Message-Status: n:0
X-SID-PRA: res06rdr@gte.net
X-SID-Result: Pass
X-Message-Info: R00BdL5giqp+ASWiiiiklZvCU/vs8FLJspkVBsjcBV2tjRy+uduwfok6NOVghSRTXzJDBesrQapIr7PY7nMfeh1Fu7JINHrJ
Received: from vms173005.mailsrvcs.net ([206.46.173.5]) by col0-mc3-f32.Col0.hotmail.com with Microsoft SMTPSVC(6.0.3790.3959);
	 Wed, 11 Nov 2009 23:40:54 -0800
Received: from [127.0.0.1] ([96.229.174.158]) by vms173005.mailsrvcs.net
 (Sun Java(tm) System Messaging Server 6.3-7.04 (built Sep 26 2008; 32bit))
 with ESMTPA id <0KSZ0027DJZU2LN4@vms173005.mailsrvcs.net> for
 palmerrh@msn.com; Thu, 12 Nov 2009 01:40:54 -0600 (CST)
Date-warning: Date header was inserted by vms173005.mailsrvcs.net
Date: Thu, 12 Nov 2009 01:40:54 -0600 (CST)
Message-id: <0KSZ0027GK052LN4@vms173005.mailsrvcs.net>
From: res06rdr@gte.net
To: Undisclosed recipients: ;
Return-Path: res06rdr@gte.net
X-OriginalArrivalTime: 12 Nov 2009 07:40:54.0868 (UTC) FILETIME=[775C7940:01CA636B]

DnepPcGmBnitvQdH+3uZpgwgQ/TcfSsJc5r0fTJIpNN
tzAgSPZwoGMUgK5iSGFY0UKq5wBXM6nA0V24P3Scg/zrrLhNxQDvxWRriqftBA6P8v50wOWm
PFVxUs7HJGahB5pAPpQM02lU0AXdMs2vr6G2T+NsE+g7n8q9TgiSGJI4xhEAUD0Fcf4Gtg0l
zdHGVAQDvzz/AErsxTARzzTF60rHJpFoAcTUZpzGmUAOooooASZv3K/XFV93y596kkP7rHoa
r5+QfWgCwz5iz6Vz/iqxF3YCZBmWLn6jvW0G4xUMvzREHtQB5mDiup8KagWV7Nz90bk+nesL
WLM2V8ygYjf5kPt6VXtrqS1nSaFsOpyKQHornBB9K53X5SqyD++5rStNQjv7HzYjhiOVHJU5
rA8Qy5uhH/cHP1NAGHJyeSKYDTpG5/8Ar0wUAOyR2pwPOaZn3pQx9KAO18C3UP8ApFsRidsO
D/eA7fh/WuwzXlWjXn2HVLe4zwrjd9Dwf0r1LORxTACaF6U2jPFAhSabQTzSZ4oAdmim5ooG
RO2eKgLcGhn+aoWbqKBD9/NM3ZJHqKiL801Xy9AzO1azW9geM/fHKH0NcW6tG7I4IZTgg9q7
u5PORWLf6XHe3QmV/LJ+9xnNICp4ZjuJdUXyWZUAzIR0x6Umv2k9pfSsVZ4nYsHHOM9jV+ZP
7PsmFm7RMuDlf4vrWJ/b2oZYSyiUHjDqP6VDvctWtYpFgaN3tRLKZpmkKqpY5wgwB+FNzVED
sn3pd31pmfejJNAEqtzXqGg3pvtHt5WOXC7WPuOK8tXiuw8D3b5uLVj8uBIo9+h/pTQjsSaC
aj3UM3NMB+aM1HmlzQAuaKjzRQBTLHdULMc0UUAREnNRxMd9FFAyGQnyz9aqAkORRRQBFegN
DIGGcIT+QNcnJ96iikwGilJoopAGKdRRQAore8IyMmtIqnh0YH6Yz/SiimhHeZoJ5oopgNya
XJoooAaDRRRQB//Z
--------------000302070301020706060601--

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 13

9 years ago
The two images included in the last email that failed were actually BMP images, and not JPEG as I had originally assumed. I will try a test with a JPEG image.
(Reporter)

Comment 14

9 years ago
Ran test. JPEG Email failed. I sent a direct copy to Ludovic so he can see the result.
I can send a paste up of original message if you want it.
Created attachment 412163 [details]
received email.

Message only contains the following header :

Delivered-To: ludovic@hirlimann.net
Received: by 10.213.106.15 with SMTP id v15cs84360ebo;
        Thu, 12 Nov 2009 20:26:39 -0800 (PST)
Received: by 10.151.2.33 with SMTP id e33mr6908844ybi.58.1258086399108;
        Thu, 12 Nov 2009 20:26:39 -0800 (PST)
Return-Path: <res06rdr@gte.net>
Received: from vms173007pub.verizon.net (vms173007pub.verizon.net [206.46.173.7])
        by mx.google.com with ESMTP id 36si5489097ywh.120.2009.11.12.20.26.38;
        Thu, 12 Nov 2009 20:26:39 -0800 (PST)
Received-SPF: pass (google.com: domain of res06rdr@gte.net designates 206.46.173.7 as permitted sender) client-ip=206.46.173.7;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of res06rdr@gte.net designates 206.46.173.7 as permitted sender) smtp.mail=res06rdr@gte.net
Received: from [127.0.0.1] ([96.229.174.158]) by vms173007.mailsrvcs.net
 (Sun Java(tm) System Messaging Server 6.3-7.04 (built Sep 26 2008; 32bit))
 with ESMTPA id <0KT100C7R5NZ0E8F@vms173007.mailsrvcs.net> for
 ludovic@hirlimann.net; Thu, 12 Nov 2009 22:26:34 -0600 (CST)
Date-warning: Date header was inserted by vms173007.mailsrvcs.net
Date: Thu, 12 Nov 2009 22:26:34 -0600 (CST)
Message-id: <0KT100C9F5O90E8F@vms173007.mailsrvcs.net>
From: res06rdr@gte.net
To: Undisclosed recipients: ;

and then some mime part.
And that message is completely broken. so no wonder nothing is visible. How was the message I received created ?
(Reporter)

Comment 17

9 years ago
Ludovic: I am not sure what you mean by how was the message created. I will send you a paste up of the original tbd message via MSN Mail.
After sending you this tbd message, Firefox is no longer selected as the browser by tbd, but MSN Explorer instead. On Firefox, select Firefox as default browser, and check now but returns: Firefox is already set as your default browser.

After receiving paste of original message which should arrive intact, ask again.
(Reporter)

Comment 18

9 years ago
I sent a Thunderbird text message with an inserted url using the Ctrl+L function to attach the page to the message, and that was also destroyed by Thunderbird. 

My previous experience is that if I just type in a link without the insert pulldown, the message is received OK. Although the link text is not formatted as a link in the compose page, by the time it has gotten to the Sent file, the text is formatted as a functional link. (Using the insert pulldown the link text IS formatted as a link on the compose page.)

I can send pastes of the original and received messages if that would be useful.

In this case the attachment is a Firefox file, perhaps because Firefox was open at that page when the Thunderbird message was composed.
(Reporter)

Comment 19

9 years ago
The message referred to in the previous comment (#18) with the attachment removed was properly transmitted by Thunderbird.

(The attachment was previously inserted using the Insert pulldown menu check box.)

Comment 20

8 years ago
do you still see this in version 3.1?
Whiteboard: [closeme 2011-03-15]
(Reporter)

Comment 21

8 years ago
I don't see this problem in Version 3.1.7
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.