McAfee anti-spam messes up TB3 toolbar by injecting a button in #mail-bar2

RESOLVED DUPLICATE of bug 386870

Status

Thunderbird
Toolbars and Tabs
RESOLVED DUPLICATE of bug 386870
8 years ago
8 years ago

People

(Reporter: random832, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When McAfee anti-spam is installed, it apparently injects a button into the toolbar in a nonstandard way (it does not install an add-on or anything like that). This goes in to #mail-bar2, which results in thunderbird becoming completely confused and having all three versions of the toolbar appear in the menu, and having 'restore default set' put everything _except_ the search bar (i.e. the old set minus search) in #mail-bar2.

Reproducible: Always

Steps to Reproduce:
1. Install McAfee Anti-spam
2. Start Thunderbird
3.
Actual Results:  
Extra toolbars with identical names

Expected Results:  
Antispam button should go in the right toolbar
Pretty sure they eventually fixed their bug 386870 screwup for Tb2, I imagine they'll eventually fix the same thing again.
Wouldn't this make this invalid, or should it go to te for investigation?
(In reply to comment #2)
> Wouldn't this make this invalid, or should it go to te for investigation?

or is better dupe of bug #386870?

here http://kb.mozillazine.org/Thunderbird_2.0_installation_issues there are workaround for the same problem in TB2.

Updated

8 years ago
Whiteboard: [support]
Blocks: 531787

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386870
You need to log in before you can comment on or make changes to this bug.